EPIC - User’s Guide
Contents

1 Plug-in Installation 1
   1.1 Prerequisites ................................................. 1
       1.1.1 Eclipse ................................... 1
       1.1.2 Perl ........................................ 1
       1.1.3 Considerations when using Cygwin ..................... 1
   1.2 Installing EPIC .............................................. 2
   1.3 Uninstalling EPIC ......................................... 2

2 Setting Up Preferences 3
   2.1 General Preferences ............................................. 3
   2.2 Code Assist .................................................. 4
   2.3 Editor ...................................................... 4
   2.4 Source Formatter .............................................. 5
   2.5 Task Tags .................................................. 6
   2.6 Templates ................................................ 6
   2.7 Associating Files with the Perl Editor ....................... 7
   2.8 CVS Setup ................................................ 7
   2.9 Setting Up the Debugger ........................................ 8

3 Perl Projects 9
   3.1 Creating a Project .......................................... 9
   3.2 Perl Include Path .......................................... 9
   3.3 Converting an Existing Project ............................... 10
   3.4 Recommended Project Layout ................................. 10
4 Eclipse Basics

4.1 Perspectives ................................................................. 12
4.2 Views ............................................................................. 12
4.3 Using Perspectives ............................................................. 13
  4.3.1 New Perspectives ......................................................... 13
  4.3.2 Configuring Perspectives ............................................... 14
  4.3.3 Saving a User Defined Perspective ................................. 15
  4.3.4 Resetting Perspectives ................................................ 15
4.4 Using Views ................................................................. 15
  4.4.1 Opening Views ............................................................. 15
  4.4.2 Moving and Docking Views .......................................... 16

5 Working with the Perl Editor .................................................. 17

5.1 Syntax Check ................................................................. 17
5.2 Explain Errors and Warnings ............................................. 17
5.3 Open Declaration ............................................................ 18
5.4 Perldoc .......................................................................... 19
5.5 Quick Reference ............................................................. 20
5.6 Code Assist .................................................................... 20
  5.6.1 Variable Inspection ....................................................... 20
  5.6.2 Module Inspection ....................................................... 20
  5.6.3 External Content Assistant ......................................... 21
5.7 Task Markers ................................................................. 22
5.8 Templates .................................................................... 22
  5.8.1 Defining Templates ...................................................... 22
  5.8.2 Using Templates ......................................................... 23
5.9 Source Formatter ............................................................ 24
5.10 Source Folding ............................................................. 24
5.11 Refactoring ................................................................. 24
  5.11.1 Extract Subroutine .................................................... 24
5.12 HTML Export ............................................................ 25
5.13 Outline View ............................................................... 26
6 Using the Perl Debugger

6.1 Launching Perl Programs ........................................ 27

   6.1.1 Launching Perl Programs in Run Mode .................. 28

   6.1.2 Re-launching a Perl Program ............................ 28

6.2 Creating Launch Configurations ................................. 29

   6.2.1 Perl Local: Running a Perl Script on the Local Machine 29

   6.2.2 Perl CGI: Run Perl Programs in a CGI Environment .... 30

   6.2.3 Perl Remote: Debug a Perl Script on a Remote Machine 31

6.3 Breakpoints ..................................................... 32

   6.3.1 Setting Breakpoints ...................................... 33

   6.3.2 Enabling or Disabling Breakpoints ...................... 33

   6.3.3 Removing Breakpoints ................................... 33

6.4 Views in the Debug Perspective ................................. 33

   6.4.1 Debug View ............................................... 34

   6.4.2 Variables View .......................................... 34

       6.4.2.1 Customizing the Variables View .................... 35

   6.4.3 Breakpoints View ........................................ 36

   6.4.4 Perl Expression View .................................... 36

6.5 Stepping Through the Execution of a Perl Program ............ 36

   6.5.1 Step Over ................................................ 37

   6.5.2 Step Into ............................................... 37

   6.5.3 Run to Return ........................................... 37

7 RegExp Plug-in ..................................................... 38

   7.1 Enabling the RegExp View .................................. 38

   7.2 Using the RegExp Plug-in .................................. 38

   7.3 Debugging Regular Expressions ............................. 39

8 Known Bugs & Problems ........................................... 40

9 References .......................................................... 41
Chapter 1

Plug-in Installation

1.1 Prerequisites

1.1.1 Eclipse

Before installing the EPIC plug-in, a recent version of Eclipse has to be installed. The minimum requirement is version 3.1 of Eclipse for EPIC 'stable' and version 3.2 of Eclipse for EPIC 'testing'.

Eclipse comes in two flavors. The SDK version contains Java IDE components and is much larger than the Platform version. If you only want to use Eclipse as a Perl IDE, the Platform version is sufficient. If you are in for Perl and Java coding, use the SDK version.

_Eclipse does not include a Java Runtime Environment (JRE). You will need a 1.4.1 level or higher Java Runtime or Java Development Kit (JDK) installed on your machine in order to run Eclipse._

Eclipse can be downloaded from www.eclipse.org.

1.1.2 Perl

In order to have all EPIC features like Syntax Checking, Source Formatting etc., a Perl interpreter is needed. In principle any Perl interpreter can be used. To use debugging within Eclipse, Perl version 5.8.x or 5.6.x is required. For further requirements concerning the debugger, see Section 2.9.

Most *nix/Linux installations will provide Perl interpreters out of the box.

Perl for Windows can be downloaded from www.activestate.com

1.1.3 Considerations when using Cygwin

Make sure that the mount command is available and that it is in your system path. As mount is a standard component of Cygwin, you usually just have to add the cygwin\bin directory to your system path.
1.2 Installing EPIC

The installation is done by using the Eclipse Update Manager. The Update Manager connects to an EPIC Update Site [http://e-p-i-c.sourceforge.net/updates]. The Update Site can also be stored locally if no Internet connection is available and can be downloaded from the EPIC project page.

After starting Eclipse, select Help → Software and Updates → Find and Install... from the menu.

Select Search for new features to install an press Next. Press the Add Update Site... button for a remote installation via HTTP or the Add Local Site... button if the Update Site is available locally. When installing EPIC from remote, enter any desired Name and the URL http://e-p-i-c.sf.net/updates.

Tick the newly created site and press the Next button. Follow the instructions of the install wizard. The warning about the installation of an unsigned feature can be ignored. Eclipse has to be restarted after installation.

Now the EPIC installation should be complete.

1.3 Uninstalling EPIC

To temporarily disable or uninstall the currently active version of EPIC, select Help → Software and Updates → Manage Configuration from the menu. Expand the tree in the dialog window which appears and select the EPIC feature. Click on the option Disable in the panel on the right side and restart Eclipse when asked. At this point EPIC is disabled, but still present on disk. To remove it completely, enter the same dialog again and select the previously disabled version of EPIC (you may need to toggle showing disabled features in the dialog’s toolbar). The option Uninstall will now remove the chosen version of EPIC completely.
Chapter 2

Setting Up Preferences

EPIC preferences can be accessed via Window → Preferences... from the Eclipse Menu.

2.1 General Preferences

![Preferences](image)

Click on Perl to open the General Preferences page.

General preferences include the location of the Perl interpreter, the option to enable warnings, taint mode and the interval of the source validation.

The validation interval indicates when to start validation after the editor becomes idle.

Apart from the standard interpreter type, the type can be switched to Cygwin. In this case the @INC path is mapped to be Cygwin compliant.

The two debugger-related preferences work as follows:

- Enable debugger console is only useful if you wish to debug EPIC itself and should not be activated otherwise. This preference causes a special console to become available while debugging Perl scripts. The console shows internal communication between EPIC and the Perl debugger backend. To access this console, you have to click on the item perl -d in the Debug view.
• Suspend debugger at first statement (active by default) causes the debugger to stop right at the beginning of the debugged script, even if there are no breakpoints set. If this preference is inactive, then the debugger will not suspend until the first breakpoint is hit (or the script finishes execution).

**Note**
On slower systems it might be useful to disable automatic syntax validation. Syntax validation is still possible by using the Shift-F5 function key.

### 2.2 Code Assist

On the Code Assist Preference Page the auto completion trigger characters are defined. Normally it should not be necessary to change these values.

By default the editor suggests a list of already used variables when the characters `@ %` are typed. To switch this feature off, deselect the Inspect Variables check box.

The External content assistant field allows advanced users to specify a custom Perl script to be used to generate autocompletion suggestions, for example to integrate project-specific suggestions or AI language models (see Section 5.6.3)).

![Code Assist Preference Page](image)

### 2.3 Editor

These options define the appearance of the Perl Editor, the coloring of the Perl source code, and how annotations are displayed.

Smart typing settings allow to switch auto-completion of quotes, parenthesis etc. on or off.
2.4 Source Formatter

EPIC uses PerlTidy to format source code. The Source Formatter Preference allows to specify PerlTidy command line parameters. To get a description of available parameters, press the Help key and select PerlTidy options from the popup menu.

Note
In order for PerlTidy to work correctly, the Perl Interpreter Preferences have to be setup correctly (see above).
2.5 Task Tags

In this section, you can specify a list of keywords that act as markers for tasks inside comments in your Perl code, i.e. tags that mark the beginning of a task entry.

By default, the words TODO and TASK mark the beginning of a task.

Check the Ignore Case option if you want EPIC to recognize task tags case-insensitively, e.g. # todo my task.

If you select Allow whitespace, task tags do not need to follow a comment sign (#) directly, e.g. # TODO my task instead of having to write #TODO my task.

See Section 5.7 to see how to use Task Tags in the Perl Editor.

2.6 Templates

Templates are a powerful tool to insert pre-defined code snippets while working with the Perl Editor.
How Templates are use is covered in Chapter 5. The Templates Preference page allows the creation, import and export of Templates.

Exported Templates are stored in XML format.

### 2.7 Associating Files with the Perl Editor

Eclipse associates file extensions with editors. If another plug-in is installed, the EPIC Perl Editor might not be used as the default editor when opening *.pl, *.pm or *.cgi files. To associate these file extensions with the Perl Editor, choose Window → Preferences... from the Eclipse menu and select Workbench → File Associations. If the Perl extensions are missing, they can be created by pressing the Add... button. Select the Perl Editor from the list and press the Default button.

![File Associations](image)

**Note**

Regrettably, there is currently no way to associate EPIC with script files that do not have any specific extension but instead begin with the `#!/usr/bin/perl` line.

### 2.8 CVS Setup

By default, Eclipse stores Perl files as binary when they are added to the CVS repository. To store Perl files as text (ASCII), select Window → Preferences... from the Eclipse menu and modify the Team → File Content settings. Add your Perl extensions (pl, pm etc.) by pressing the Add... button and specify ASCII in the Contents column.
2.9 Setting Up the Debugger

Setting up the debugger requires two steps:

1. Define the Perl interpreter to use.
2. Install the PadWalker Perl module.

**Note**

It is possible to use the debugger without installing PadWalker, but in this case local variables won’t be shown.

Download the PadWalker module from CPAN (PadWalker 1.5) and install as described in the installation notes or use the installation manager provided with your Perl installation (e.g. PPM for ActiveState installations).

Earlier versions of EPIC provided a custom-compiled version of PadWalker for ActiveState 5.8.x. This is no longer necessary; you should simply use the most recent version of PadWalker distributed by ActiveState.
Chapter 3

Perl Projects

3.1 Creating a Project

Perl projects are created (like any other project) by selecting File → New → Project... from the Eclipse menu.

Follow the wizard’s instructions to create your Perl Project. Perl Projects appear with a custom folder icon in the Navigator view: 🌐

3.2 Perl Include Path

To add entries to a project’s Perl Include Path (@INC), right click on the project icon and select Properties.... If non-absolute paths are entered, they are interpreted as relative to the project folder. Standard Eclipse variables (e.g. ${{project_loc}}) can also be used.
3.3 Converting an Existing Project

To add the Perl Nature to an existing project, select the project in the Navigator and select Add Perl Nature from the context menu.

To remove the Perl Nature from a project, select the project and select Remove Perl Nature from the context menu.

3.4 Recommended Project Layout

In order to avoid problems with syntax validation (such as packages reported missing) and the debugger (such as skipped breakpoints), it is best to organize your project according to the conventions of the core Perl distribution:

- Keep your own modules in dedicated subtrees of your project. For example, create a subdirectory `lib` as the root of the subtree containing all `.pm` files. Note that you can have more than one such subtree. For example, you could also create `test/lib` to store modules that are only imported by test scripts.

- Add the root directories of your subtrees to the `@INC` path (see [?title]). For example, add the entries `lib` and `test/lib` there.

- Map package names to paths in the subtree (and vice versa). For example, store code for the package `Foo::Bar` in file `lib/Foo/Bar.pm` and ensure that `lib/Foo/Baz.pm` contains only package `Foo::Baz`. 
• Store your Perl scripts anywhere you like in the project. For example, in subdirectory `bin` or `cgi-bin`.

• To import from a package, use it, rather than require it. For example, `use Foo::Bar;` rather than `require '../lib/Foo/Bar.pm';`
Chapter 4

Eclipse Basics

4.1 Perspectives

Each Workbench window contains one or more perspectives. A perspective defines the initial set and layout of views in the Workbench window. Within the window, each perspective shares the same set of editors. Each perspective provides a set of capabilities aimed at accomplishing a specific type of task or works with specific types of resources. For example, the Java perspective combines views that you would commonly use while editing Java source files, while the Debug perspective contains the views that you would use while debugging Java programs. As you work in the Workbench, you will probably switch perspectives frequently.

Perspectives control what appears in certain menus and toolbars. They define visible action sets, which you can change to customize a perspective. You can save a perspective that you build in this manner, making your own custom perspective that you can open again later.

You can set your Workbench preferences to open perspectives in the same window or in a new window.

The main perspectives for developing Perl applications are:

- This is the main perspective for coding Perl scripts.
- Provides the main functionality for debugging and executing Perl scripts. For details see Section 6.4.

4.2 Views

Views support editors and provide alternative presentations as well as ways to navigate the information in your Workbench. For example, the Navigator view displays projects and other resources that you are working with.

Views also have their own menus. To open the menu for a view, click the icon at the left end of the view’s title bar. Some views also have their own toolbars. The actions represented by buttons on view toolbars only affect the items within that view.

A view might appear by itself, or stacked with other views in a tabbed notebook. You can change the layout of a perspective by opening and closing views and by docking them in different positions in the Workbench window.
4.3 Using Perspectives

4.3.1 New Perspectives

There are several ways to open a new perspective within this Workbench window:

- Using the Open Perspective button on the shortcut bar.
- Choosing a perspective from the Window → Open Perspective menu.

To open one by using the shortcut bar button:

1. Click on the Open Perspective button.

2. A menu appears showing the same choices as shown on the Window → Open Perspective menu. Choose Other from the menu.

3. In the Select Perspective dialog choose Debug and click OK.

The Debug perspective is displayed.

4. There are several other interesting things to take note of.
   - The title of the window now indicates that the Debug perspective is in use.
• The shortcut bar contains several perspectives, the original Resource perspective, the new Debug perspective and a few others. The Debug perspective button is pressed in, indicating that it is the current perspective.

• To display the full name of the perspective right click the perspective bar and check Show Text.

5. In the shortcut bar, click on the Resource perspective button. The Resource perspective is once again the current perspective. Notice that the set of views is different for each of the perspectives.

4.3.2 Configuring Perspectives

In addition to configuring the layout of a perspective you can also control several other key aspects of a perspective. These include:

• The New menu.

• The Window → Open Perspective menu.

• The Window → Show View menu.

• Action sets that show up on the toolbar.

Try customizing one of these items.

1. In the shortcut bar click on the Resource perspective.

2. Select Window → Customize Perspective....

3. Select the Commands tab.

4. Check Launch and click OK.
5. Observe that the toolbar now includes buttons for debug/run launching.

6. After experimenting with the other options on the Customize Perspective dialog, choose Window → Reset Perspective to return the perspective to its original state.

### 4.3.3 Saving a User Defined Perspective

If you have modified a perspective by adding, deleting, or moving (docking) views, you can save your changes for future use.

1. Switch to the perspective that you want to save.
2. Click Window → Save Perspective As.
3. Type a new name for the perspective into the Name field.
4. Click OK.

### 4.3.4 Resetting Perspectives

To restore a perspective to its original layout:

1. Click Window → Preferences.
2. Expand Workbench and choose Perspectives.
3. From the Available perspectives list, select the perspective you want to restore.
4. Click Reset.
5. Click OK.

### 4.4 Using Views

#### 4.4.1 Opening Views

Perspectives offer pre-defined combinations of views and editors. To open a view that is not included in the current perspective, select Window → Show View from the main menu bar.

You can create fast views to provide a shortcut to views that you use often.

After adding a view to the current perspective, you may wish to save your new layout by clicking Window → Save Perspective As.
4.4.2 Moving and Docking Views

To change the location of a view in the current perspective:

1. Drag the view by its title bar. Do not release the left mouse button yet.

2. As you move the view around the Workbench, the mouse pointer changes to one of the drop cursors shown in the table below. The drop cursor indicates where the view will be docked if you release the left mouse button. To see the drop cursor change, drag the view over the left, right, top, or bottom border of another view or editor.

3. When the view is in the location that you want, relative to the view or editor area underneath the drop cursor, release the left mouse button.

4. (Optional) If you want to save your changes, select Window → Save Perspective As from the main menu bar.

5. Note that a group of stacked views can be dragged using the empty space to the right of the view tabs.
Chapter 5

Working with the Perl Editor

5.1 Syntax Check

EPIC performs on-the-fly syntax check of Perl source files. In order for the Syntax Check to work, the Perl Interpreter has to be set up correctly (see Chapter 2).

The Syntax Check is performed after a defined idle period, after the user has stopped typing. This idle period can be configured in the preferences.

When an error/warning has been found, the editor displays the appropriate icon in the annotation ruler (the gray bar on the left side of the editor), underlines the error in the source, and inserts a marker into the Problems view.

A syntax check can be enforced by pressing Shift-F5. It is also triggered automatically by saving a source file.

5.2 Explain Errors and Warnings

In addition to displaying warnings and errors, the editor is capable of explaining them in more detail.
To get an Error/Warning explanation, right-click the Error/Warning icon and select Explain Errors/Warnings from the context menu.

The explanation(s) will be displayed in the Explain Errors/Warnings view:

5.3 Open Declaration

Open Declaration allows the user to search for the declaration of a specific subroutine or package.
The search first determines what is selected. If no text is selected, it attempts to find a subroutine or package name at the current cursor position. The search will fail if neither is selected.

Due to the dynamic nature of Perl programs, the search is not entirely reliable. For package names and subroutine names qualified by a package prefix, an attempt will be made to locate the appropriately named module file using the @INC path. For unqualified subroutine names, the search will first occur in the current editor and then extend to modules referenced by ‘use’ and (literal) ‘require’ statements.

If the declaration is found, it will be highlighted in an existing or new editor.

## 5.4 Perldoc

To retrieve Perldoc information, select a keyword or text and choose Perldoc from the context menu or press Shift-Ctrl-H. If nothing is selected, an input dialog will appear.

The search is performed among built-in Perl functions, FAQs from the Perl documentation, and modules on the include path (see [?title]). If Perldoc entries are found, they are displayed inside the Perldoc view.

**Note**

Perldoc has to be installed and available in the system PATH, otherwise this feature will not work.
5.5 Quick Reference

Apart from Perldoc support, a quick reference feature is available. This feature has the advantage that no perldoc has to be installed on the system but does not provide as much information as perldoc.

To view the Quick Reference, select a keyword and move the mouse pointer over the selection. A tooltip with a short description of the keyword should appear.

5.6 Code Assist

Code Assist features try to assist the user during source code editing.

**Note**
The features currently implemented in EPIC are rudimentary. An option to utilize a user-defined script for code assist suggestions is provided to allow integration of more powerful, external code generation tools.

5.6.1 Variable Inspection

When you press one of the auto completion characters $ @ %, the editor displays all defined variables in a list. From the list you can select the variable that should be inserted in the source code.

5.6.2 Module Inspection

The editor tries to display methods available in modules when the auto completion characters > or : are entered.
Note
Currently, indirect object invocations are not recognized by code assist. This code block will not work:

```perl
$smtp = new Net::SMTP;
$smtp->[no content assist]
```

This one will work:

```perl
$smtp = Net::SMTP->new();
$smtp->[content assist]
```

### 5.6.3 External Content Assistant

If specified on the Code Assist preferences page, a user-defined Perl script can be used to compute autocompletion suggestions instead of or in addition to EPIC’s built-in ones. It is called by EPIC with the following arguments:

- documentPath = workspace-relative path of the edited source file (if available),
- documentOffset = selection start offset in the document/file (or caret position if there is no selection),
- selectionLength = length of selection (0 if there is no selection),

and the entire source document is passed in as standard input.

Based on the provided information the script is supposed to generate on standard output a list of autocomplete suggestions or "proposals" which, if not empty, take precedence over EPIC’s built-in generation. Each suggestion contains instructions to insert/replace a contiguous piece of text at a given position in the source document and move the caret to a new position. A suggestion is formatted as a comma-separated list of "replacementOffset,replacementLength,newCursorPosition,replacementString":

- replacementOffset = where to insert the proposal in the file (typically = documentOffset),
- replacementLength = how many characters to remove at this offset (typically 0, i.e. just insert),
• newCursorPosition = where to place caret after the insertion, relative to replacementOffset (typically = replacementString.length()),

• replacementString = what to insert at replacementOffset

Suggestions are separated from each other by the special `<|proposal|>` token.
Refer to the source code of org.epic.perleditor.editors.util.ExternalAutoComplete for further implementation details.

5.7 Task Markers

Task markers are a very convenient way to add items to the Eclipse task list. A task marker is generated when a `#TODO any text` is found in the Perl source code. On deletion of the `#TODO` comment, the task marker is also deleted.

You can customize the keywords which begin task markers in the preferences (see Section 2.5).

5.8 Templates

Templates allow for easy insertion of predefined text segments. In addition to normal text these segments can also include pre-defined variables that are included at runtime as well as variables that are specified by the user when the template is inserted.

5.8.1 Defining Templates

Templates are defined in the EPIC Preferences (Window → Preferences...). To define a new template, press the New... button.
To insert pre-defined variables, press the Insert Variable... button.

In addition to pre-defined variables, the user can specify additional variables (using the syntax \${varname}) which can be edited when the template is inserted. When the first variable is inserted, variables with the same name will automatically be changed.

### 5.8.2 Using Templates

Templates are invoked by typing some characters and pressing Ctrl-Space. Templates matching the typed characters will be displayed in a list. A preview is also available.

If the template contains user defined variables the user can press the TAB key to jump to the next variable after the template has been inserted.
5.9 Source Formatter

EPIC uses PerlTidy for source code formatting (PerlTidy is included in the EPIC package). To format the source code, select Source → Format from the Eclipse menu or use Ctrl-Shift-F. PerlTidy settings can be changed in the Source Formatter preference page.

**Note**
Source formatting might take a while if the source code has a lot of lines.

5.10 Source Folding

The editor supports folding of POD comments and subroutines.

Source folding can be disabled in the Editor preference page.

**Note**
On big files source folding can decrease performance. So if you experience slowdowns, disabling source folding might help.

5.11 Refactoring

5.11.1 Extract Subroutine

Extraction of subroutines is supported by the use of the CPAN Devel::Refactor module. To extract a subroutine, mark the code to extract and select Refactor → Extract Subroutine from the popup menu.
In the popup menu insert the name of the new subroutine and press **Enter**.

The new subroutine will be placed at the end of the Perl script (before **__END__** section) and the selection will be replaced with the subroutine call.

---

**Note**
The extraction might not work properly at the moment because the Devel::Refactor module is in an early stage of development. With upcoming versions of the module, this function should become more reliable.

---

### 5.12 HTML Export

To export, select Source → Export → HTML from the Eclipse menu and specify an output file. HTML export settings can be changed in the Source Formatter preference page.

---

**Note**
For HTML export to work, a working Source Formatter is needed (see [?title]).
5.13 Outline View

The Outline view displays packages and subroutines defined in the edited file. Modules referenced by ‘use’ statements are also shown. When you click on a module or subroutine name in the outline, the editor will jump to the appropriate position in the source code. When the cursor is moved inside of a subroutine’s definition, the subroutine will become selected in the outline.

Subroutines named `new` will get a different icon.
Chapter 6

Using the Perl Debugger

6.1 Launching Perl Programs

You may launch your Perl programs from the workbench. Programs may be launched in either run or debug mode.

- In run mode, the program executes, but may not be suspended or examined.
- In debug mode, execution may be suspended and resumed, variables may be inspected, and expressions may be evaluated.

The environment a Perl program is to be executed in is defined via "Launch Configurations". A launch configuration defines

- if the program is to be executed in a CGI or normal Perl environment
- the host the program is to be executed on
- the program to execute
- execution parameters to pass
- environment variables
- configuration data for the web server used to provide the CGI framework
6.1.1 Launching Perl Programs in Run Mode

1. Select Run → Run... from the Eclipse menu.

2. Within the appearing dialog, select the configuration type:
   - Perl Local: Run a Perl script on the local machine
   - Perl CGI: Run Perl programs in a CGI environment on the local machine
   - Perl Remote: Run a Perl script on a remote machine

   and press the New button to create a new launch configuration.

3. Adjust launch configuration attributes. For details see Section 6.2.

4. Press the Run button.

This executes the program. The program’s console output will be shown in the console window. For "Perl Local" and "Perl Remote" configurations, the console window also accepts keyboard input to be passed to the program.

If you switch to the debug view, you have additional control over the execution of the program. For details see Section 6.4.1.

6.1.2 Re-launching a Perl Program

The workbench keeps a history of each launched and debugged program. To relaunch a program, do one of the following:

- Select a previous launch from Run or Debug button pull-down menus.
• From the menu bar, select Run → Run History or Run → Debug History and select a previous launch from these sub-menus.

• In the Debug view, select a process that you want to relaunch, and select Relaunch from the process’s pop-up menu.

To relaunch the most recent launch, do one of the following:

• Click the Run or Debug buttons (without using the button pull-down menu).

• Select Run → Run Last Launched (Ctrl-F11), or Run → Debug Last Launched (F11) from the workbench menu bar.

### 6.2 Creating Launch Configurations

#### 6.2.1 Perl Local: Running a Perl Script on the Local Machine

1. Enter the name for the launch configuration in the Name field.

2. In the Main tab

   • Project field: select the project which contains the script to execute

   **Note**
   Only Perl projects (projects associated with a Perl nature) will be shown. If the project you require is not shown, see Section 3.3 for adding a Perl nature to your project.

   • File to execute field: select the script to execute

   **Note**
   Only files associated with the Perl editor will be shown. See Section 2.7 for details.
3. If you wish to pass command-line parameters to the script or to the Perl interpreter, enter them in the Arguments tab.

4. If you wish to modify environment variables for the script, enter them in the Environment tab.

**Note**
Be careful when removing or overriding the standard environment variables. For example, the environment variable %SYSTEMROOT% is essential for Perl socket IO to work under Windows.

5. Press the Apply button

### 6.2.2 Perl CGI: Run Perl Programs in a CGI Environment

1. Enter the name for the launch configuration in the Name field.

2. In the Web Server tab
   - HTML Root Directory field: enter the base directory that contains all HTML files or use the Browse button to select the appropriate directory.
   - HTML Startup File field: enter the file name to be shown in the browser after startup or use the Browse button to select this file.
   - CGI Root Directory field: enter the base directory that contains all CGI files or use the Browse button to select the appropriate directory.
   - Extension for CGI files field: this is a comma separated list of file extensions (each starting with a "." ) used for CGI files in the project.

3. In the Browser tab, there are two possible settings:
   - Select Custom Browser: specify the path to the browser executable and add the required command line parameters. Use %1 as a place holder for the HTML file to be opened.
   - Select Default System Browser to use the browser defined as default browser by your OS preferences.
4. If you wish to modify environment variables for the script, enter them in the Environment tab.

5. If you wish to pass command-line parameters to the Perl interpreter, enter them in the Arguments tab.

6. Press the Apply button.

6.2.3 Perl Remote: Debug a Perl Script on a Remote Machine

**Note**
This feature is not tested very well and should be considered experimental.

Some points to consider:

- You need a Perl interpreter installed on the remote host.

- During debugging the remote host connects to the local (Eclipse) host using three TCP ports: the debugger port, the stdout/stdin port and the stderr port. The debugger port is specified statically in the launch configuration (see below). The two other ports are picked up from the range 5000-10000. (EPIC attempts to reserve these ports in ascending order starting with 5000.) Make sure that your firewall does not block these required connections.

- Scripts executed and code shown are from different sources: EPIC displays the code present on your local host and executes a copy of this code on the remote host. So if you make changes within your project please make sure to transfer these changes to the remote host (see below for further details). This problem gets more significant for code/modules provided by your Perl installation. If modules on your local and remote host differ, debugging results may be quite meaningless. So try to have the same Perl version installed on both hosts and make sure all modules you require (which are not part of your Eclipse project) are identical.

- `@INC` path handling: if the include path references directories within your project or directories that are linked into your projects, EPIC will include these modules in the list of files to be copied to the remote host and adjust the `@INC`-path for your remote host accordingly. Overall, it is best to set up project-relative `@INC` paths in the project properties.
1. Enter the name for the launch configuration in the Name field.

2. In the Configuration tab
   - Project field: select the project to debug.
     
     **Note**
     Only Perl projects (projects associated with a Perl nature) will be shown. If the project you require is not shown, see Section 3.3 for adding a Perl nature to your project.

   - File to execute field: select the Perl file to execute.
     
     **Note**
     Only files associated with the Perl editor will be shown. See Section 2.7 for details.

3. Local Host IP: this is the IP-address used by the remote host to connect to your local host. In most cases the default value is appropriate.

4. Target Host Project Installation Path: the project’s location on the remote host. Make sure that your Eclipse project can be found at this location.

5. Port: Port used by the remote debugger to connect to the local host.

6. Create Debug Package: if checked, a ZIP file containing the project files to be transferred to the remote host is created. This file is stored at the location indicated in Debug Package File Path.

7. Press the Debug button. At this point, the local host starts listening for a remote debugger connection.

8. Extract the ZIP file to the location on your remote host indicated in Target Host Project Installation Path.

9. Start the script `start_epicDB.pl` on your remote host (it is included in the ZIP archive and thus located in the project directory after extraction). This script starts the debugger and makes it connect to the local host.

10. Enjoy debugging...

### 6.3 Breakpoints

The Perl debugger supports *line breakpoints* and *regular expression breakpoints*. Both types of breakpoints are set on an executable line of a program. If enabled, they suspend thread execution before the corresponding line of code is executed. Regular expression breakpoints additionally extract the regular expression contained in the line of code they are associated with and enable you to debug the regular expression within the RegExp-Plugin.

The following symbols are used to indicate breakpoints:
### 6.3.1 Setting Breakpoints

1. In the editor area, open the file where you want to add the breakpoint with the Perl editor.

2. Directly to the left of the line where you want to add the breakpoint, open the marker bar (vertical ruler) pop-up menu and select Add Breakpoint or Add RegExp Breakpoint.

While the breakpoint is enabled, thread execution suspends before that line of code is executed.

### 6.3.2 Enabling or Disabling Breakpoints

Open the debug view, open the Breakpoints view and use the check box in front of the break point to enable or disable the break point.

### 6.3.3 Removing Breakpoints

There are two possible ways for removing a breakpoint:

1. Right click on the breakpoint symbol in marker the bar (vertical ruler) of the editor pop-up menu and select Remove Breakpoint.

2. Open the debug perspective, open the Breakpoints view, right-click the breakpoint you want to remove and select Remove.

### 6.4 Views in the Debug Perspective

If any of the views described below is not visible, you can open it using the Window → Show View menu.

#### Table

<table>
<thead>
<tr>
<th>Status</th>
<th>Line Breakpoint</th>
<th>Regular Expression Breakpoint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enabled</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Disabled</td>
<td>○</td>
<td></td>
</tr>
<tr>
<td>Registered with debugger</td>
<td>•</td>
<td></td>
</tr>
</tbody>
</table>

**Note**

Regular Expressions Breakpoints are still in an experimental state and will at the moment only work for expressions of the type: `Expr1 =~ <delim>regexp<delim>modifiers;` Modifiers are ignored.
6.4.1 Debug View

This view allows you to manage the debugging or running of programs in the workbench. It displays the stack frames for the suspended program you are debugging. It also displays the process for each target you are running.

If the program is suspended, its stack frames are shown as child elements. Clicking on a stack frame takes you to the corresponding line in the Perl editor and updates contents of the Variables view. If necessary, a new editor is opened automatically.

**Note**

EPIC does not currently include support for debugging multi-threaded programs.

6.4.2 Variables View

When a stack frame is selected, you can see the visible variables in that stack frame in the Variables view. The view shows the value of primitive (scalar) types. Variables which point to data structures such as hashes, lists or objects can be examined by expanding them to show their members. Variables that are references are dereferenced to show the final scalar value or data structure pointed to by the reference chain (or an indication of cyclic reference).

Global variables (including Perl internal variables) are marked with an \(\text{\textbullet}\) icon, local variables with an \(\text{\textbullet}\) icon.
6.4.2.1 Customizing the Variables View

You can customize the presentation with the configuration menu:

**Show Details Pane**

To show the detail pane select Vertical View Orientation or Horizontal View Orientation. Select Variables View Only to disable it. The details pane shows the value of primitive variables (especially useful for string variables).

**Highlight Updated Variables**

If you enable this option, the variables whose values have changed during the last execution step (since the last suspend) and new variables will be highlighted. If a change has occurred inside of a complex variable, the variable will be highlighted and the path to the changed value will also be indicated using delta symbols:

![Highlighted Variables Example]

This makes it possible to see these kinds of changes even if variables are collapsed.

---

**Note**

This feature requires EPIC to retrieve and remember the value of every variable on each suspend. It may be very slow for larger programs (e.g. it might take about 20 seconds for a program containing data structures with 5000+ values). For this reason, the option is disabled by default and should be used with care.

---

**Select Variables to Display**

The variables view allows to select the following types of variables for displaying by checking the corresponding menu entry:

- **Perl Internal Variables**: these are variables provided by the Perl interpreter like `$_`, `@INC` etc.

- **Global Variables**: variables visible from everywhere in your program. More precisely, these are the variables from the symbol table of the package in which the debugger is suspended or from the main package (in scripts).

- **Local Variables**: variables declared with the keyword `my`, more correctly called "lexical" variables in Perl. To show lexical variables, you need to install the Perl PadWalker module. The PadWalker module has some problems which influence viewing of local variables.
Show Addresses of Variables

By default, EPIC shows the address to which a reference variable points, but it does not show the address of each non-reference variable. This additional information can be helpful when you wish to check which variable is pointed to by a reference. When enabled, the address of each variable (including scalar variables) will be displayed right before its value.

6.4.3 Breakpoints View

![Breakpoints View](image)

The Breakpoints view shows all breakpoints (see Section 6.3), their state and location. By selecting one or more breakpoints and invoking the context menu, you can enable, disable or remove these breakpoints.

6.4.4 Perl Expression View

![Perl Expression View](image)

The Perl Expression View allows you to execute any valid Perl code within the current context of the program executed in debug mode.

1. Open the view (Window → Open View → Other, then EPIC → Perl Expression View).
2. Enter the code to execute.
3. Press the `.` symbol.

6.5 Stepping Through the Execution of a Perl Program

When a thread is suspended, the step controls can be used to step through the execution of the program line-by-line. If a breakpoint is encountered while performing a step operation, the execution will suspend at the breakpoint and the step operation is ended.
6.5.1 Step Over

1. Select a stack frame in the Debug view. The current line of execution in that stack frame is highlighted in the editor in the Debug perspective.

2. Click the Step Over button ( ) in the Debug view toolbar, or press the F6 key. The currently selected line is executed and suspends on the next executable line.

6.5.2 Step Into

1. Select a stack frame in the Debug view. The current line of execution in that stack frame is highlighted in the editor in the Debug perspective.

2. Click the Step Into button ( ) in the Debug view toolbar, or press the F5 key. The next expression on the currently selected line to be executed is invoked, and execution suspends at the next executable line in the method that is invoked.

6.5.3 Run to Return

1. Select a stack frame in the Debug view. The current line of execution in that stack frame is highlighted in the editor in the Debug perspective.

2. Click the Run To Return button ( ) in the Debug view toolbar, or press the F7 key. Execution resumes until the next return statement in the current subroutine is executed, and execution suspends on the next executable line.
Chapter 7

RegExp Plug-in

7.1 Enabling the RegExp View

To display the RegExp view, select Window → Show View → Other... from the Eclipse menu and select the EPIC → RegExp view from the list.

7.2 Using the RegExp Plug-in

The RegExp plug-in is a small tool to debug regular expressions.

To check if a regular expression is valid, press the Run icon. If the regular expression matches the text, it will be signaled by a green icon. If the regular expression contains brackets, the matching character groups in text will be colored.

Regular expression shortcuts are available via the context menu.
7.3 Debugging Regular Expressions

The Single Step feature allows for a step by step inspection of the regular expression.

If no groups (...) are defined by the user, the RegExp Plug-in tries to use logical blocks for matching, otherwise the already existing groups are used.

The following buttons are provided:

- ▼ Reset (clears all color markers)
- ▼ Step forward
- ▼ Step backward
Chapter 8

Known Bugs & Problems

The Bugs and Feature Requests trackers on SourceForge contain descriptions of the current open issues for EPIC. If you encounter a problem, you can also search the Help forum for previous reports and solutions and ask your question there.
Chapter 9

References

Part of this document is taken from the official Eclipse documentation provided by the Eclipse project and IBM.

EPIC uses the public domain ANTLR 2 library developed by Terence Parr and others in the ANTLR project.