Again, variables not showing in debug

adebree wrote on Wed Aug 20 23:31:30 MEST 2008:
Hi there,

I've read a lot about people having the same problem I'm having: in debugging
the Variables not showing. None of the tips / suggestions solved it for
me, so I'm hoping to find a sollution this way. 

In short I'm using Windows XP PROF UK SP3, Sun Java JRE 1.5, Eclipse 3.4,
ActivePerl 5.10 (have tried cygwin's perl with the same result), PadWalker
1.7 from PPM - Bribes repository (and CPAN for the Cygwin try) and EPIC
0.6.25 (Perl Debug Plug-in being 0.6.19).

I've used a 2 lines perl test file:

my $x = 'foo';
print $x; 

Having the default 'suspend at first line' option active, but when debugging
nothing shows up in the 'variables' view. Even not after stepping to the
next line. All 'show' options of the 'variables' view are checked.

By suggestion of Jan in some earlier threads I've turned on debug console
and the output when debugging is as follow:

Loading DB routines from version 1.3
Editor support available.

Enter h or `h h' for help, or `perldoc perldebug' for more help.

main::(C:/12. Workspaces/Try/PerlTry/bin/
1:	my $x = 'foo';
  DB<1> printf $DB::OUT "%vd", $^V;
  DB<2> print $DB::OUT eval { require PadWalker; PadWalker->VERSION(0.08)
  DB<3> ;{
my $file = <<'EOT';
C:/12. Workspaces/Try/PerlTry/bin/
my $line = <<'EOT';
my $cond = '';

epic_breakpoints::add_breakpoint($file, $line, $cond);

  DB<4> .
main::(C:/12. Workspaces/Try/PerlTry/bin/
1:	my $x = 'foo';
  DB<5> T
  DB<6> .
main::(C:/12. Workspaces/Try/PerlTry/bin/
1:	my $x = 'foo';
  DB<7> .
main::(C:/12. Workspaces/Try/PerlTry/bin/
1:	my $x = 'foo';
  DB<8> .
main::(C:/12. Workspaces/Try/PerlTry/bin/
1:	my $x = 'foo';
  DB<9> .
main::(C:/12. Workspaces/Try/PerlTry/bin/
1:	my $x = 'foo';
  DB<10> .
main::(C:/12. Workspaces/Try/PerlTry/bin/
1:	my $x = 'foo';
  DB<11> ;{
do '' unless defined &dumpvar_epic::dump_package_vars;

my $savout = select($DB::OUT);

3|$^E|1|1|17|SCALAR(0x1911e4c)|18|'Access is denied'|2|18

It might be the 'Access is denied' in this debug output, but no clue where
that refers to.

Toggling between a different view and the variables results in a minor addition
to the debug console:

do '' unless defined &dumpvar_epic::dump_package_vars;

my $savout = select($DB::OUT);


This plugin has a nice potential and since I've come from a pure classic
vi setup it's a joy having all these convenience bells and whistles available.
The variables inspector would be the icing on the top ;)

Anyone having a good suggestion?

Gr, Arne
jploski wrote on Thu Aug 21 08:32:02 MEST 2008:
1. The long list you see in the debug console are the transmitted variables
- their names and values, one per line.
2. The variable $x does not show up in that list. However, that's normal
if the debug console contents you provided was captured before stepping
to the second line. Before the variable has been defined, it does not show
up in the Variables view - this is expected. Can you post the content from
the debug console *after* stepping over the my $x = 'foo' line - does the
$x (or any suspicious messages) show up in the console then?
3. I think that the "Access is denied" is irrelevant - it is just the value
of the built-in variable $^E
4. Have you tried selecting global and Perl internal variables to be shown
using the pulldown menu of the Variables view (after the debugger is running)?
Do these variables show up correctly (you may need to relaunch debugger
to see them)?
adebree wrote on Thu Aug 21 20:06:16 MEST 2008:
Thx for the quick response Jan!

After some further fiddling around with Eclipse it apears that the 'Enable
taint mode' (on the 'Perl EPIC' preferences tab, which I kind of enabled
by instinct...) is the cause of the variables not appearing. I've turned
it off and now the debugger does present the variables to me. yay! ;)

I guess it's 'solved' for now, will try to find some time to do a replication
test on another system about this behaviour. Or is it it by design and am
I missing a point?
jploski wrote on Thu Aug 21 20:21:06 MEST 2008:
It's not by design, and I can't reproduce it on my Linux machine.

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.