Can't invoke Perl from EPIC

gocbgo wrote on Thu Aug 17 18:23:12 MEST 2006:
Hi!  Running on Windows XP, Eclipse 3.2.

EPIC installs OK, but when trying to run a Perl program, I get:

Could not start Debug Process!
  Failed to execute command line: "C:\Perl\bin\perl.exe" "file:E:\plugins\org.epic.debug_0.4.0.jar!/"
CreateProcess: C:\Perl\bin\perl.exe file:E:\plugins\org.epic.debug_0.4.0.jar!/

I think the error=267 indicates a bad directory.  The argument to perl.exe
looks a little weird.  When I run that command from a command-line, I get:

C:\TEMP>C:\Perl\bin\perl.exe file:E:\plugins\org.epic.debug_0.4.0.jar!/
Can't open perl script "file:E:\plugins\org.epic.debug_0.4.0.jar!/":
Invalid argument



However, C:\Perl\bin\perl.exe is indeed the Perl interpreter on my machine,
and E:\plugins\org.epic.debug_0.4.0.jar exists and contains

Is there additional logging anywhere that would contain more information?

doikota wrote on Fri Aug 18 13:43:23 MEST 2006:
Hi, actually I had exactly the same trouble but I tried the following and
it worked.

unzip the "org.epic.debug_0.4.0.jar" as follows.

1) Create the folder under plugins as,

2) Rename the "org.epic.debug_0.4.0.jar" to "" in
order to enable to unzip. Don't leave "org.epic.debug_0.4.0.jar" as is.
Otherwise, Eclipse still seeks this jar file.

3) Unzip the contents of "" under the folder "org.epic.debug_0.4.0"

4) Re-start Eclipse and run your perl script.

Actually, when I tried to run the EPIC with my different PC, this didn't
happen (only difference I could imagine is 1st PC is using JDK5.0 but 2nd
PC is using JDK1.4.2). So I wonder if somebody could give some comments
on it, especially from the technical perspective, it would be great. 
gocbgo wrote on Fri Aug 18 21:24:05 MEST 2006:
Thank you Kotaro,

This solved the problem!  I am also running at JDK 1.4.2.  I will respond
to the other subthread as well for debugging purposes.
jploski wrote on Sun Aug 20 20:44:59 MEST 2006:
I think maybe you downloaded the update site archive and then instead of
installing it using the Update Manager (as described in the contained README.txt)
unzipped the contents to your features/plugins directory.

Your described manual unzipping trick is an acceptable fix. I don't believe
the Update Manager does much (anything?) beyond that... Of course, the safest
remedy would be to remove org.epic.* from $ECLIPSE_HOME/plugins and $ECLIPSE_HOME/features
and reinstall properly (as I understand you already have done).
jgangemi wrote on Fri Aug 18 15:57:25 MEST 2006:
i'm not sure why your path is referencing a jar file instead of just a directory.

how did you install the plugin?
gocbgo wrote on Fri Aug 18 21:26:20 MEST 2006:
Hi Jae,

I installed via the update site on top of a clean Eclipse install.  I have
manually unzipped the package in the past but not on this installation.
 It's possible I made a mistake and had some junk left over from a previous
installation but I doubt it.  Let me know if there is any other info I can

Running JDK 1.4.2 on Windows XP.
gocbgo wrote on Fri Aug 18 21:27:24 MEST 2006:
p.s. EPIC is awesome.  Thank you for producing this.
doikota wrote on Sat Aug 19 00:35:25 MEST 2006:
Hi, I just want to correct my status. I should say the differnece is not
coming from JDK 5.0 and JDK 1.4.2. I again checked my 1st PC and it has
the directory, "org.epic.debug_0.3.2", but not "org.epic.debug_0.4.0" directory
nor "org.epic.debug_0.4.0.jar". I must apologize if I mislead you guys to
the wrong direction. Sorry about that. Yes, EPIC is great.
jgangemi wrote on Sat Aug 19 04:33:12 MEST 2006:
have you tried removing the plugin directories yourself, and clearing the
config cache? (start eclipse w/ the -clean option, but only start it that
way once) and then reinstalling epic?
gocbgo wrote on Sun Aug 20 12:48:38 MEST 2006:
I haven't, but I did just a clean install of eclipse+epic on another machine
and it worked great without any hackery.  I'm willing to chalk this up to
gremlins but will continue to monitor the forum to try to reproduce in case
anyone else reports it.

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.