command-line arguments in EPIC

llzamboni wrote on Wed Oct 18 18:42:15 MEST 2006:
My Perl script takes a command line argument, but I cannot figure out how
to enter a command-line arg in EPIC.  A solution was offered in another
thread as follows:

"Under "External Tools" select your program and add  
${string_prompt} to your Arguments line. This will spawn a text prompt when
you run the script where you can type in any arguments you wish."

I tried this solution and a prompt did appear.  I entered in my file name
(no quotes around it or anything), and this still did not work.

A launching error dialog box appeared and said "Exception occured executing

What am I doing wrong?


jploski wrote on Wed Oct 18 18:52:35 MEST 2006:
The solution you mention is very outdated. Do not use External Tools for
launching Perl scripts.

With EPIC 0.4.x or 0.5.x you should create a launch configuration of type
Perl Local (under Run/Run...) and enter the arguments on the Arguments tab.
llzamboni wrote on Wed Oct 18 19:00:17 MEST 2006:
When I enter the arguments on the argument tab, should I enter them in the
Program Arguments or Perl Arguments?

At any rate I tried both and the error is:
Program Arguments:
"Can't open Abronia_submit_for_load_02-May-2006: No such file or directory
at C:/Documents and Settings/lgifford/workspace/ITIS Update/ line

Perl Arguments:
"Can't open perl script "Abronia_submit_for_load_02-May-2006": No such file
or directory"

jploski wrote on Wed Oct 18 19:15:28 MEST 2006:
You should enter the script's arguments in "Program Arguments". "Perl Arguments"
are only needed if you want to pass options to the Perl interpreter (which
normally come before the script's name).

So - what did you enter in Program Arguments and what does your
script do in line 36? The argument passing seems to be working fine to me.
llzamboni wrote on Wed Oct 18 19:37:15 MEST 2006:
Thanks for the help.  I got it to work.  Your solution was correct.  And
thanks for the explanation of the difference between the two types of arguments
llzamboni wrote on Wed Oct 18 19:12:36 MEST 2006:
Never mind.  I figured out why using your solution was not working for me.
 Thanks for the help!

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.