Debugger error

yoyota wrote on Fri Jun 29 08:14:48 MEST 2007:
My system environment is:
+ Windows XP 
+ Eclipse SDK, Version: 3.2
+ ActivePerl 5.8.8
+ Java(TM) Runtime Environment 6.0 Update 1 
+ Padwalker 1.5

I could run the perl code withour any problem. But when I debug the code,
it outputs:
Unable to connect to remote host: *.*.*.*(IP Address):5000
Compilation failed in require.
 at F:/Develop/perl/ line 0
	main::BEGIN() called at F:/Develop/java/.metadata/.plugins/org.epic.debug/
line 0
	eval {...} called at F:/Develop/java/.metadata/.plugins/org.epic.debug/
line 0
BEGIN failed--compilation aborted.
 at F:/Develop/perl/ line 0

Then pops up a dialogue: Time out while waiting for Perl Debugger connection.

This error has been discussed in the previous post at
but it seems not been solved. 
I have shut down my firewall, and my environment variable '$SystemRoot'
exists and is 'C:\windows'. 

The most strangest thing is: I have tried this on another computer, and
it seems the debugger could works well.
yoyota wrote on Fri Jun 29 08:17:53 MEST 2007:
sorry for the link of the previous post:
jploski wrote on Sun Jul  1 12:04:57 MEST 2007:
Enable debug console in preferences, so that the exact command line and
environment used to start the Perl debugger is logged to the Error Log view
(and to the file WORKSPACE/.metatdata/.log).

Start the EPIC debug session and then go into a DOS box and check with netstat
whether EPIC is listening on port 5000 (it should be). Try connecting to
this port (using the IP address as shown in .log) with telnet.

You can also try reproducing the problem without EPIC:
1) Start a netcat process (download netcat.exe from somewhere if you don't
have it) listening on some port, i.e.
netcat.exe -l -p 5000
2) Set up environment as EPIC does and run perl -d in a DOS box

The perl -d process should connect to the netcat process and you should
be able to control it using the netcat console. If you get the same error,
then EPIC does not contribute to your problem and you should look for a
solution in your system configuration (firewall, network configuration maybe?)

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.