Debugger not working with Cygwin Perl

amire80 wrote on Sun Jun  3 17:19:11 MEST 2007:
I am using Eclipse 3.2.2 and EPIC 0.6.5.

I used to work with ActivePerl and the EPIC debugger gave me a lot of trouble,
probably because of PadWalker. I gave up on installing PadWalker with ActivePerl
and tried to move to Cygwin.

Installing PadWalker from CPAN in the Cygwin environment was very easy.
I defined the correct Perl executable and selected "Cygwin" as "interpreter
type". Perl programs seem to be executing correctly, but the EPIC debugger
still doesn't work as i would expect.

The Variables view says: "An error occurred while dumping global variables;
contents of the Variables view may become invalid"

The Expressions view says "Watch expressions not supported" (are they supposed
to work if everything is installed correctly?)

Thanks in advance.
mz2guild wrote on Sat Aug  4 06:13:59 MEST 2007:
wow, i got a same problem, but it was cleaned.

i upgrade active perl 5.8.8
and install padwalker 1.0 using ppm 4.0

and Download Eclipse Perl Integration (EPIC) 0.6.4 for EasyEclipse 1.2.2:

you able to use following link.(EPIC) 0.6.4 with easyeclipse 1.2.2:

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.