Debugger not Working -

billbell52 wrote on Mon Jul 24 19:07:55 MEST 2006:
I may have spoke to soon on this working.  It worked on a simple program
but when I tried to connect to Oracle I get the following,  I checked for
PadWalker and it is there.  When I do other simple programs I can see the
variables.  Any ideas.

Error Parsing Debugger Variables
  +++++++Error Parsing Vars++++++
of uninitialized value in string eq at /home/billb/eclipse/plugins/org.epic.debug_0.3.2//
line 233.
  	dumpvar_epic::unwrap('DBI::db=HASH(0x864a898)',3,-1) called at /home/billb/eclipse/plugins/org.epic.debug_0.3.2//
line 138
  	dumpvar_epic::DumpElem('DBI::db=HASH(0x864a898)',3,-1) called at /home/billb/eclipse/plugins/org.epic.debug_0.3.2//
line 410
  	dumpvar_epic::dumplex('$dbh','REF(0x8584398)',-1) called at (eval 18)[/apps/perl/5.8.0/lib/5.8.0/]
line 2
  	eval '($@, $!, $^E, $,, $/, $\\, $^W) = @saved;package main; $^D = $^D
| $DB::db_stop;
  ;{eval { require PadWalker; PadWalker->VERSION(0.08) }or print $DB::OUT
("PadWalker module not found - please install\\n");do \'\'
unless defined &dumpvar_epic::dumpvar_epic;defined &dumpvar_epic::dumpvar_epic
or print $DB::OUT " not available.\\n";my $h = eval { PadWalker::peek_my(2)
};my @vars = split (\' \',\'\');$@ and $@ =~ s/ at .*//, print $DB::OUT
($@);my $savout = select($DB::OUT);dumpvar_epic::dumplex($_,$h->{$_},defined
$option{dumpDepth} ? $option{dumpDepth} : -1,@vars) for sort keys %$h;print
  ;' called at /apps/perl/5.8.0/lib/5.8.0/ line 17
  	DB::eval called at /apps/perl/5.8.0/lib/5.8.0/ line 1323
  	DB::DB called at /home/billb/workspace/AC/ line 35
  S0000000e  NS00000008$dirnameS0000000c'/data/arch'NS00000016$export_connect_stringS00000082'apex/apexprod@
  +++++++Error Parsing Vars++++++

Program  -- works when you run it from command line.

#!/apps/perl/5.8.0/bin/perl -w
$| = 1;
use strict;
use DBI;
use DBI qw(:sql_types);
use DBD::Oracle qw(:ora_types);
use File::Find;
use Data::Dumper; $Data::Dumper::Indent=1;

my $DEBUG = 1; ## verbose
#my $dirname = "s:/links/arch";     # PC
my $dirname = "/data/arch";
my $username = 'xxxxxx';
my $password = 'xxxxxx';
my $hostname = '';
my $sid = 'XXXXXX';

my $hashref;

my $export_connect_string = qq($username/$password@ (DESCRIPTION=

my $dbh = DBI->connect('dbi:Oracle:',$export_connect_string,"", {
  ChopBlanks => 1,
  ShowErrorStatement => 1,
  FetchHashKeyName => 'NAME_uc',
  AutoCommit => 0,
  PrintError => 1,
  RaiseError => 1
} ) or  die "Can't connect to database: $DBI::errstr\n";

jploski wrote on Mon Jul 24 19:27:40 MEST 2006:
Can you reproduce the problem without the Oracle stuff? Note that your password
got revealed in the debug message.
jploski wrote on Mon Jul 24 19:48:43 MEST 2006:
Does debugging work if you remove -w from the first line?
billbell52 wrote on Thu Jul 27 15:52:07 MEST 2006:
It worked.  Removing the -w and everything seems to work. 

Thanks...and more thanks.

bryceman wrote on Fri Jul 28 23:41:36 MEST 2006:
So why do warnings have to be disabled?
jploski wrote on Sat Jul 29 00:00:30 MEST 2006:
A bug in the (EPIC) debugger, I think. It seems difficult to reproduce without
the Oracle environment.
bryceman wrote on Sat Jul 29 00:21:43 MEST 2006:
Oracle environment? My script has absolutely nothing to do with that. I'll
see if I can narrow down a test case.

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.