Debugger problems in Eclipse 3.1

yurezz wrote on Mon Aug 22 18:00:47 MEST 2005:
Hello All, 

I use Eclipse 3.1 with EPIC Project 0.3.11.
Perl version 5.8.7 build 813
Perl Editor Plug-In 0.2.1
RegExp Plug-In 0.1.3
Debug Plug-In 0.3.1

Also I download and install PadWalker package for Perl from

I know that a lot of peoples has already wrote about the same problem but
I don't find any solutions for my it and try ask again...

Debugger don't stop on any breakpoints!
How to fix it? 

In Eclipse 3.0 it's work fine but I have problems with showing local variables.
Solution in documentation by using dummy() function is not best way I'm
afraid... :-\
Is exists some combination with Eclipse and Perl where debugger works fine?

jploski wrote on Mon Aug 22 18:36:04 MEST 2005:
I don't see a bug report which would match your problem (ignored breakpoints).
Perhaps you should add one. Do not forget to include the relevant contents
of your /.metadata/.log file and the simplest source code which
lets you reproduce this bug.

The debugger stops for me at breakpoints as expected, both the 0.3.11 and
the CVS version. However, I only tried it under Linux.
jploski wrote on Tue Aug 23 09:35:06 MEST 2005:
You should try the org.epic.debug version from CVS. It seems to work properly
under Windows with the Eclipse, Perl and Padwalker versions you use.

The 0.3.11 version does not even display stack frames for me in Eclipse
3.1 under Windows (no variables, no error messages either).
yurezz wrote on Tue Aug 23 11:48:55 MEST 2005:
Thanks a lot for your answer, Jan! 
I work under Windows (XP SP2) now and perhaps under Linux is everything
is fine...
Anyway I'll try to get org.epic.debug version from CVS and try test it again.


ijb13 wrote on Tue Aug 23 21:04:02 MEST 2005:
I am experiencing the same problem under Fedora Linux FC4

The error message from .log is:

!ENTRY org.eclipse.core.runtime 4 2 2005-08-23 11:57:51.846
!MESSAGE An internal error occurred during: "Initialize Debug View".
        at org.eclipse.debug.internal.ui.views.launch.LaunchView.findFrame(
        at org.eclipse.debug.internal.ui.views.launch.LaunchView.access$5(
        at org.eclipse.debug.internal.ui.views.launch.LaunchView$
oyku wrote on Mon Aug 29 21:13:12 MEST 2005:
How is epic installed from CVS?
jploski wrote on Mon Aug 29 23:32:50 MEST 2005:
Here is how it goes. The process is generic, so you may wish to read up
on setting up and installing any Eclipse plugin project elsewhere (eg. in
Eclipse's online help).

First, check out
as Java projects into your workspace.

Then make sure that all the projects compile with no errors. At first, they
won't. You will have to import Eclipse plugins on which EPIC depends into
your workspace (using the option File/Import.../External Plug-ins and Fragments).

In each of the EPIC plugin projects there is the plugin manifest file plugin.xml.
Right-click on it and select "PDE Tools/Create Ant Build File". This will
create a build.xml file in the top-level directory of the plugin.

Finally, you have to run the created build.xml (Run As/Ant Build... from
the context menu) with target "zip.plugin". This will create a zip archive
with plugin's "deliverables", which you can unzip into $ECLIPSE_DIR/plugins.
Repeat it for all of the four plugins mentioned above.
dacypher wrote on Tue Aug 30 15:27:24 MEST 2005:
Anyone feel like uploading a compiled version of EPIC from CVS somewhere?
pacanukeha wrote on Tue Aug 30 19:27:24 MEST 2005:
That would be stirling!  Perhaps the compile could be built into an eclipse
update format?
jploski wrote on Sat Sep  3 00:18:42 MEST 2005:
I uploaded a version compiled from CVS to FileFront (SourceForge did not
accept the file as RFE attachment for some reason - size?). Click on "more
details about this file" for installation instructions:;4090819;;/fileinfo.html
dacypher wrote on Wed Sep  7 15:22:49 MEST 2005:
Thanks Jan, much appreciated.
pacanukeha wrote on Wed Sep  7 17:47:59 MEST 2005:
The CVS build now allows me to launch the CGI debugger correctly as well.
jploski wrote on Sun Sep 18 22:27:56 MEST 2005:
"EPIC testing 0.3.12" is released and newer (better) than the CVS version
linked from the above post. Therefore, I removed the uploaded file and the
link no longer works - use "EPIC testing" instead.
illvilja wrote on Wed Sep  7 21:20:40 MEST 2005:
Well, I ran into something similar when running the debugger for Perl in

Once debugging started, I could never do a normal "step over/into/outof"
etc (the buttons were always greyed out) and even if the code appearently
paused at the breakpoints, I never got it to display in the code editor
which line it were about to execute.  Also, there were never a "Stack trace"
symbol displayed in the "Debug" window in Eclipse.

The solution were to download Eclipse 3.0.2 and then install EPIC 0.3 once
again.  After doing that, the debugging worked as expected: the "step over/into/outof"
buttons were active, the code editor indicated the current line to execute
and there was a stack trace symbol for the file.

So, until either Eclipse or EPIC have their next release, I'll stick to
Eclipse 3.0.2 and EPIC 0.3.  I understand that the CVS versions of Eclipse
works, but it is easier for my workmates to use fixed versions with well
known sets of features and bugs.

Great tool!  I'll continue to explore it for our Perl development!

Best regards


(Redhat Advanced Server 4, Eclipse 3.1, 
aroushdi wrote on Mon Sep 19 09:30:57 MEST 2005:
I have downloaded 3.12 and tried it with Eclipse 3.02 and 3.1 and still
cannot make it to work . It complains about gui  in the preference pages
and then the debug . May be i am missing a module . Epic works fine with
3.02 and 3.11
thanks again for ur help
jploski wrote on Mon Sep 19 19:51:15 MEST 2005:
Explain what you mean by "complains about gui"?

Are you referring to this bug (known open issue)?

Or maybe to this one (should be fixed in 0.3.12)?

Or something entirely different?
aroushdi wrote on Tue Sep 20 09:53:13 MEST 2005:
I have created a new thread since it seems new . Thks
marcbernst wrote on Sun Jan  8 05:49:56 CET 2006:
Why is this still unresolved after 4 months?
jploski wrote on Sun Jan  8 10:26:35 CET 2006:
(The two bugs I mentioned earlier are resolved in CVS.)

EPIC has no budget, too few active developers, no dedicated QA people, too
busy administrators, and some users with high expectations. ;-)
marcbernst wrote on Mon Jan  9 05:30:22 CET 2006:
I appreciate the monumental efforts involved in producing the perl plugin
and do not fault in the least your commitment to the process. I also expect
that the project will eventually be a valuable perl tool. 

I simply wish  I had been warned more clearly before investing the significant
time I did in setting up a tool that is basically useless. I certainly don't
have the time or knowledge to 'try' the cvs version. I assume I would have
to know enough to extract from CVS and build the plugin. Are there really
just two of you working on EPIC development? In your spare time?


marcbernst wrote on Sun Jan  8 05:50:01 CET 2006:
Why is this still unresolved after 4 months?
ronw_000 wrote on Sat Jan 14 06:04:57 CET 2006:
I have been using EPIC 3.12 and Eclipse 3.1 on Win XP with ActiveState Perl
5.8.4 with the EPIC PadWalker ActiveState 5.8.1 for for a few months now
and the debugger is working better than the EPIC 3.11 Eclipse 3.0.2 and
it is quite a bit snappier in response.  The upgrade from Eclipse 3.0.X
to 3.1 can be a bit tricky but I feel the end result justifies the effort.
 The usual caveats apply, rebuild your workspace, make sure the perl binary
is properly selected in the Eclipse/EPIC preferences, make sure that the
Perl debugger and PadWalker is installed correctly.  (Note: on ActiveState
Perl I have been  more successful installing the ActiveState PadWalker via
PPM and then overwriting it with the EPIC PadWalker by unzipping over the
ActiveState version.)  I'll be trying it on OpenSuSE shortly and I'll try
to report back my results.
donkeybandit wrote on Wed Jan 18 17:58:39 CET 2006:
Alternatively you could update using the Software Update tool at the address

This will install via the update method rather than CVS jiggery pokery.
(Current release is 0.3.12).

The single stepping all worked for me, once it was updated.

Hope this helps!
sumadartson wrote on Fri Jan 27 23:58:09 CET 2006:
The install via the software update worked like a charm under the following

Linux (Ubuntu)
Perl 5.8.4
Eclipse 3.1
Padwalker 1.0


Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.