Difficulties with @INC

dwballance wrote on Wed Dec  6 06:56:10 CET 2006:
I have a project that includes files that reference a .pm in a folder not
included in the project. Even though I have included the path to that .pm
in the project properties "Perl Include Path", the Problems window shows
the error "Can't locate myexternal.pm in @INC (@INC contains: C:/Perl/Lib
C:/Perl/site/lib)". What do I need to do to have the warning correctly show
@INC that includes my additional search paths?

I have tried both forward- and backward-slashes in the Perl Include Path
entries. Neither seems to change this.

I'm using EPIC 0.5.24, Eclipse 3.2.1.

Thanks for any assistance.
jploski wrote on Wed Dec  6 19:15:21 CET 2006:
Please see the debugging suggestion in thread https://sourceforge.net/forum/forum.php?thread_id=1626716&forum_id=258688
dwballance wrote on Fri Dec  8 17:35:27 CET 2006:
Well, mystery solved, and I'm pleased to report it was a rookie error and
nothing to do with EPIC. The error message was being generated by a separate
project, whose @INC had not been changed. (I am sorry to have posted an
erroneous question).

I do have a followup question - if I wanted to manually run the syntax check
(i.e. from a console rather than from within Eclipse), what is the command
for that?
jploski wrote on Fri Dec  8 18:31:09 CET 2006:
The command is "perl -c". Of course, you also need to specify your include
path if you try it (for example "perl -I c:/this -I c:/that -c script.pl").
dwballance wrote on Fri Dec  8 19:00:07 CET 2006:
Thanks! Just what I needed.

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.