Editor Instability on Linux - Not on PC

billbell52 wrote on Mon Nov 13 22:21:07 CET 2006:
I run EPIC on both the PC and Linux environments.  I am finding the Linux
environment unstable.  I have yet to crash the PC install.  I have tried
to make the Linux and PC (Windows XP) environments the same - Latest Eclipse,
latest EPIC, Perl 5.8.  I run Linux via a VNC connection to the PC.
As an example of the Linux instability I typed a brace rather than an open
parenthesis and they I tried to select some text in that area.  My VNC session
crashed.  I restarted the VNC session and tried to open Eclipse and it would
not start.   I edited the file and corrected the error stand-alone and then
reopened Eclipse and it worked.

I am not seeing this on the PC.  

Are others seeing this?  Any ideas?

I'll try to create some smaller test case and post.  

jploski wrote on Mon Nov 13 22:44:22 CET 2006:
I develop and use EPIC under Linux and find it stable. Indeed, there seem
to be several UI update quirks under Windows (degraded performance), so
I'd recommend Linux as the platform of choice for EPIC.

The reported crashing of a VNC session is not related to Eclipse or EPIC
whatsoever. VNC sessions are quite unstable in my experience, but simply
reestablishing such a session should bring you back to the same state of
the desktop with the Eclipse/EPIC running.

OTOH, when you experience a crash of the Java virtual machine, then a file
called hs_err_pidNNNN.log is usually left behind in the directory where
Eclipse executed. Looking at its content may give you some clues about the
source of problems. Generally, EPIC is not to blame for JVM crashes, as
they are caused by bugs in the virtual machine itself or (more likely) native
libraries in the OS environment. For example, I've had some crashes caused
by libgtk-2.0 in Debian unstable recently. These seem to have been fixed
by a simple upgrade of this library.

If Eclipse refuses to start, have a look at the file called $WORKSPACE/.metadata/.log
to find out why.
billbell52 wrote on Mon Nov 13 23:02:52 CET 2006:
I do have a hs_err_pid file.  Here is a small piece of it.  I have no idea
what it is telling me.  I did not find a $WORKSPACE/.metadata/.log file.

lindesk02(72)> more hs_err_pid12013.log
# An unexpected error has been detected by HotSpot Virtual Machine:
#  SIGSEGV (0xb) at pc=0xb1b4287d, pid=12013, tid=3074973824
# Java VM: Java HotSpot(TM) Server VM (1.5.0_05-b05 mixed mode)
# Problematic frame:
# j  org.eclipse.swt.internal.gtk.OS._pango_layout_get_indent(I)I+0

---------------  T H R E A D  ---------------

Current thread (0x0805bb30):  JavaThread "main" [_thread_in_native_trans,

siginfo:si_signo=11, si_errno=0, si_code=0, si_addr=0x00000000

EAX=0x00000000, EBX=0x6f7f6b80, ECX=0xb6afaecc, EDX=0x6f7fb130
ESP=0xbfffb730, EBP=0xbfffb760, ESI=0x6f7f6b80, EDI=0x0805bb30
EIP=0xb1b4287d, CR2=0xb6afaecc, EFLAGS=0x00010286

Top of Stack: (sp=0xbfffb730)
0xbfffb730:   00000000 6f7fb130 0805bbec bfffb768
0xbfffb740:   65ba8ea8 bfffb744 00000000 bfffb770
0xbfffb750:   6f7fb130 00000000 6f7f6b80 bfffb770
0xbfffb760:   bfffb790 b1b3ca3f 6f7fb098 b1b40639
0xbfffb770:   65ba8ea8 bfffb774 6f7f6c28 bfffb7a4
0xbfffb780:   6f7fb130 00000000 6f7f6c60 bfffb7a4
0xbfffb790:   bfffb7c4 b1b3ca3f 00000000 00000000
0xbfffb7a0:   00000000 65ba8ea8 bfffb7a8 702a9d18

Instructions: (pc=0xb1b4287d)
0xb1b4286d:   cf c1 e9 02 81 e1 fc 0f 00 00 81 c1 00 a0 af b6
0xb1b4287d:   89 09 81 3d 78 1a 06 b7 00 00 00 00 0f 85 0d 00

Stack: [0xbfe00000,0xc0000000),  sp=0xbfffb730,  free space=2029k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native
j  org.eclipse.swt.internal.gtk.OS._pango_layout_get_indent(I)I+0
j  org.eclipse.swt.internal.gtk.OS.pango_layout_get_indent(I)I+8
j  org.eclipse.swt.graphics.TextLayout.getIndent()I+8
j  org.eclipse.swt.custom.StyledText.getPointAtOffset(I)Lorg/eclipse/swt/graphics/Point;+216

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  org.eclipse.swt.internal.gtk.OS._pango_layout_get_indent(I)I+0
j  org.eclipse.swt.internal.gtk.OS.pango_layout_get_indent(I)I+8
j  org.eclipse.swt.graphics.TextLayout.getIndent()I+8
j  org.eclipse.swt.custom.StyledText.getPointAtOffset(I)Lorg/eclipse/swt/graphics/Point;+216
v  ~C2IAdapter
J  org.eclipse.swt.custom.StyledText.setStyleRanges(II[I[Lorg/eclipse/swt/custom/StyleRange;Z)V
v  ~I2CAdapter
j  org.eclipse.swt.custom.StyledText.replaceStyleRanges(II[Lorg/eclipse/swt/custom/StyleRange;)V+29
v  ~C2IAdapter
J  org.eclipse.jface.text.TextViewer.addPresentation(Lorg/eclipse/jface/text/TextPresentation;)V
v  ~I2CAdapter
j  org.eclipse.jface.text.TextViewer.changeTextPresentation(Lorg/eclipse/jface/text/TextPresentation;Z)V+117
j  org.eclipse.jface.text.presentation.PresentationReconciler.applyTextRegionCollection(Lorg/eclipse/jface/text/TextPresenta
j  org.eclipse.jface.text.presentation.PresentationReconciler.processDamage(Lorg/eclipse/jface/text/IRegion;Lorg/eclipse/jfa
j  org.eclipse.jface.text.presentation.PresentationReconciler.access$3(Lorg/eclipse/jface/text/presentation/PresentationReco
j  org.eclipse.jface.text.presentation.PresentationReconciler$InternalListener.textChanged(Lorg/eclipse/jface/text/TextEvent
j  org.eclipse.jface.text.TextViewer.updateTextListeners(Lorg/eclipse/jface/text/TextViewer$WidgetCommand;)V+81
j  org.eclipse.jface.text.TextViewer.invalidateTextPresentation(II)V+92
j  org.eclipse.jface.text.source.AnnotationPainter.invalidateTextPresentation()V+129
j  org.eclipse.jface.text.source.AnnotationPainter.updatePainting(Lorg/eclipse/jface/text/source/AnnotationModelEvent;)V+18
j  org.eclipse.jface.text.source.AnnotationPainter.access$1(Lorg/eclipse/jface/text/source/AnnotationPainter;Lorg/eclipse/jf
j  org.eclipse.jface.text.source.AnnotationPainter$1.run()V+31
v  ~C2IAdapter
J  org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Z)Z
J  org.eclipse.swt.widgets.Display.readAndDispatch()Z
J  org.eclipse.ui.internal.Workbench.runEventLoop(Lorg/eclipse/jface/window/Window$IExceptionHandler;Lorg/eclipse/swt/widget
v  ~OSRAdapter
j  org.eclipse.ui.internal.Workbench.runUI()I+225
j  org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Lorg/eclipse/swt/widgets/Display;Lorg/eclipse/ui/application/Work
j  org.eclipse.ui.PlatformUI.createAndRunWorkbench(Lorg/eclipse/swt/widgets/Display;Lorg/eclipse/ui/application/WorkbenchAdv
j  org.eclipse.ui.internal.ide.IDEApplication.run(Ljava/lang/Object;)Ljava/lang/Object;+76
jploski wrote on Mon Nov 13 23:25:16 CET 2006:
Maybe you should report this bug (by quoting the full error file) at https://bugs.eclipse.org
File a report against Classification = Eclipse, Product = Platform, Component
= SWT there, as the crash occured in SWT code.

You might also wish to experiment with things like:
1. upgrading the pango library
2. changing the GTK theme (there seem to be a few older bugs related to
3. examining installed fonts to check for any strangeness
...or just ignore it and hope that it does not occur again!
jploski wrote on Mon Nov 13 23:26:52 CET 2006:
One more idea, you may also try downgrading to Eclipse 3.1.2, as the SWT
method in which the crash occured does not exist in that older version.

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.