Environment broken since 0.3.9?

ftak wrote on Mon Jan 31 13:26:51 CET 2005:
I'm using EPIC 0.3.10 with Ecplise 3.01 on Windows XP SP2. Up to version
0.3.8 everthing worked fine, but now I'm not able to run some of my scripts
from Eclipse as paths and enviroment settings seem to have gone :-(

One example: DBI, DBD::Oracle is not able to find its oci.dll any more:
"Error: Error while connecting to DB: install_driver(Oracle) failed: Can't
load 'C:/Sprachen/Perl/site/lib/auto/DBD/Oracle/Oracle.dll' for module DBD::Oracle:
load_file:Das angegebene Modul wurde nicht gefunden at C:/Sprachen/Perl/lib/DynaLoader.pm
line 229.
 at (eval 76) line 3
Compilation failed in require at (eval 76) line 3.
Perhaps a required shared library or dll isn't installed where expected."

When I copy the oci.dll to the given directory, other errors occur ("oracle
home dir not set" etc.)...

Running the scripts from the command line still works fine.

Was there any change in the enviroment handling since 0.3.8?
pguzis wrote on Mon Jan 31 19:05:38 CET 2005:
See the associated bug report at https://sourceforge.net/tracker/index.php?func=detail&aid=1111125&group_id=75859&atid=545274
ftak wrote on Tue Feb  1 13:25:53 CET 2005:
Thanks, updating to 0.3.10 from 0.3.9 didn't help, but after reinstalling
0.3.10 everything works fine again :-)
ngmilne wrote on Wed Mar 16 19:12:33 CET 2005:
I'm running the latest 0.3.10 pulled from the update site directly into
eclipse and my environment is empty - I've tried reinstalling without success.
I need the PATH set so my script can pick up Sybase DLL files.

I've checked the bug report but it doesn't say what the actual fix was,
or which files were missing so I can check if they are there or not in my

Any ideas?
pguzis wrote on Wed Mar 16 19:19:43 CET 2005:
I believe the culprit was a missing file that preserved the environment
during script launch.

Try removing EPIC and installing the latest version.  That fixed it for

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.