Error Parsing Debugger Variables bug fixed?

x_hu wrote on Sun Sep 17 08:26:43 MEST 2006:
It’s weird that I can run any of my Perl scripts perfectly well, but every
time when I tried to debug it with Eclipse, an error report window popped
up: Error Parsing Debugger Variables.

All the stuffs required in the EPIC User’s Guild or Build Perl applications
with Eclipse were installed. They are:
Eclipse 3.2 (also installed JDK 1.5)
ActivePerl 5.8.8 build 819
EPIC stable version 0.4.0 (updated to 0.4.10)
PadWalker for ActiveState Perl 5.8.1 or higher

Running on Windows XP Home Edition.

Later I tried to disable the stable version 0.4.x and installed the testing
version 0.5.x which has its ChangeLog says:
Version 0.5.5 - 4-September-2006
		* Fixed Bug [ 1546237 ] Error parsing debugger variables
But again, nothing good happens. Bug is still there.

This happens even when I am debugging the simplest code: print “Hello
Everything works well if I debug the code with Komodo.
x_hu wrote on Sun Sep 17 08:44:08 MEST 2006:
I have been searching the solution for days, and read lots of post. I even
tried the method which mentioned by Jan Ploski in Fabian Seither's post.
But it didn't work. I guess this is the most weird thing I have met after
I started using Eclipse.

The second weird problem is …
When I’m using  to get the keyboard input, it will block the Print
Function output until the input was done.

For example:
print “Please give me a number.\nâ€;
chomp($number = );

That print line was supposed to display before  triggered. But the
fact is, I have to type the number into the console section and press ENTER.
Then the print line appears.
jploski wrote on Sun Sep 17 10:43:31 MEST 2006:
As for the first problem, check that you patched your correctly
(check that the patched routine is returning whole, not cut off strings).
If you are sure you did, open a bug report and post full details there,
preferably the ones which were reported in Fabian's thread, as well as information
whether you have warnings enabled in Preferences and/or your source code.

As for the second problem, see bug #1544625
x_hu wrote on Sun Sep 17 18:39:47 MEST 2006:
Oh, btw, seems there is no need to amend any more. I have tested
both un-patched and patched, the debugging processed properly
and the “Error Parsing …†report window didn’t pop up at all.

And thanks for the solution of the second “bugâ€. It works.
x_hu wrote on Sun Sep 17 18:30:13 MEST 2006:
Hey, Ploski. You know what? The problem was solved by changing only one
simplest setting:

Bring up the Regional and Language Options panel. Under the Standards and
formats settings (which is in the Regional Option tab), change the number/time/currency/date
setting to English (U.S.). Leave the Location setting untouched, and then
press OK to apply the change.

Now, everything goes all right. No Error Parsing Debugger Variables "bug"
any more. 

I guess the problem was caused by the lack of support of EPIC for Chinese
Localized Windows. (Why I know that? ‘Cause I am a Chinese guy whose regional
setting was Chinese (PRC). And under that circumstance, the debugger didn’t
work properly.)

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.