Installation of 0.6.24 fails cause of deps

technaton wrote on Sat Jul 12 17:34:44 MEST 2008:

I'm trying to install EPIC 0.6.24 using the Eclipse update manager. A few
days ago I already did this and it worked without problems. Today I needed
to install Eclipse's XML editor, but couldn't, because E-P-I-C had unsatisfied
dependencies. The error message was:

Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.6.1,0.6.1]]
and Match[requiredCapability: org.eclipse.equinox.p2.iu/org.epic.regexp/[0.1.4,0.1.4]]
can be satisfied.

I removed E-P-I-C to get the XML editor installed, but re-installation of
EPIC wasn't possible (same error message). I opened the updates site in
my browser to look for the required components; while org.epic.regexp_0.6.1.jar
is there, org.epic.regexp_0.1.4.jar is missing, only version 0.1.3 shows

Do I make any mistake or is there just a file missing on the updates site?

Thanks in advance for any help. :-)

    -- Eric
jploski wrote on Sat Jul 12 21:44:47 MEST 2008:
The real question is why it needs org.epic.regexp 0.1.4 at all? Do you have
some older versions of EPIC lying around in $ECLIPSE_HOME/plugins and $ECLIPSE_HOME/features?
In that case, it would be worth a try to delete them from there.
technaton wrote on Sat Jul 12 21:56:36 MEST 2008:
No, it is a fresh install of Eclipse 3.4. No old versions lying around.
I've installed E-P-I-C (together with all the other plugins I normally need,
e. g. PyDev, Ruby integration, Subclipse, etc.), and as I wrote, the initial
installed worked. But then the update manager showed that dependency.

By the way, I just checked my plugin folder an there *is* regexp 0.1.4 lying
around, perhaps from the first working installation?

I tryed wget'ing the whole updates site and dropped the 0.1.4 regexp that
was lying on my HDD, but the dependencies don't get resolved. (Of course
I added the directory as a local site in Eclipse.) Anything else I need
to do other than just copying the missing .jar to the testing/plugins directory
of my local site?
technaton wrote on Sun Jul 13 16:48:05 MEST 2008:
I just found the solution.

I did a recursive grep for org.epic.regexp in my $ECLIPSE_HOME/features
folder and found out that not E-P-I-C is requiering 0.1.4, but the Ruby
plugin. I removed the RDT and installing EPIC worked again.

Interestingly, if you remove *both* EPIC and RDT and then re-install them
in one single action (along with the rest you want to have), it works perfectly,
too. I don't quite get why this works, but afterwards installing something
completely different fails again with the same error message...

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.