Installing on Eclipse 3.3.2

paul_l_allen wrote on Fri Jun 20 21:27:32 MEST 2008:
Installing EPIC from the update site on my 3.3.2 setup (Europa) is
blocked by an error claiming that the resulting configuration would
not include the platform.  (Excuse me?)

The first question is, "What's up with that?".

Second is, if I wanted to install manually and see what happens,
what would I download?  I see one feature and lots of plug-ins.
The feature is a jar file, but my eclipse/features directory only
contains subdirectories.  If I download the latest version of each
plug-in jar and put them in my eclipse/plugins directory, would the
right thing happen?

I have tinkered with EPIC a couple times in the past, but the lack
of support for extensionless files in Eclipse has always sent me 
back to vi.  Now I see the Eclipse platform guys claim to have added
"Open With..." support as a workaround in 3.3.  It's time to check
EPIC out again.

Paul Allen
jploski wrote on Fri Jun 20 21:54:38 MEST 2008:
Which version of EPIC are you trying to install and what update site URL
are you using? It could be an intermittent problem with (try again)
or something about your Eclipse installation (reinstall Eclipse). I just
checked that both 'stable' and 'testing' versions of EPIC install fine in
3.3.2 Build id: M20080221-1800, Linux.

If you really want to do it the hard way and install EPIC by downloading
the individual plugins and features, you're supposed to have a directory
called 'org.epic.feature.main_0.6.24' in $ECLIPSE_HOME/features and the
following files/directories under $ECLIPSE_HOME/plugins:

-rw-rw-r-- 1 jpl jpl  291483 Jun 20 21:50 org.epic.debug_0.6.18.jar
drwxrwxr-x 4 jpl jpl    4096 Jun 20 21:50 org.epic.doc_0.6.1
drwxrwxr-x 4 jpl jpl    4096 Jun 20 21:50 org.epic.lib_0.6.1
-rw-rw-r-- 1 jpl jpl 1033772 Jun 20 21:50 org.epic.perleditor_0.6.16.jar
-rw-rw-r-- 1 jpl jpl   24259 Jun 20 21:50 org.epic.regexp_0.6.1.jar
drwxrwxr-x 4 jpl jpl    4096 Jun 20 21:50 org.epic.source_0.6.24

However, given that the normal way of installing doesn't work for you, who
knows whether this will help.
jploski wrote on Fri Jun 20 21:56:48 MEST 2008:
Note that someone has posted another suggestion for editing extension-less
paul_l_allen wrote on Sat Jun 21 04:17:36 MEST 2008:
The version I tried was the latest stable from
The problem is not transient.  As soon as I tell it I want the EPIC
feature, it greys out the Finish button and tells me my configuration
will not include the platform.

I downloaded the latest versions of the six jars in the update site's
plugins directory and dropped them in my eclipse/plugins.  It worked
just like a normal plugin install using a zipfile, except it was slightly
more cumbersome.

May I suggest that offering a simple zipfile that can be unpacked in
the eclipse directory would be a nice touch?  The Eclipse automated
update mechanism is sweet when it works, but my experience is that it
works only some of the time.  I haven't seen this particular failure
before.  The usual one is a missing dependency, with the message offering
no clue about what to go look for.

Paul Allen

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.