Missing breakpoints while CGI debugging

tjnicolson wrote on Wed Sep 28 09:54:51 MEST 2005:

I've found a number of references to this problem, but no solution... sorry
to post again!

Basically, I'm using Eclipse 3.1.0 and EPIC 0.3.12 (although I've tried
other versions and had the same problem), I can debug perl scripts no problem.
 However, when I start a "Perl CGI" debug session, the browser is started,
and the script is run, but EPIC doesn't stop at the beginning of the perl
code (or at any of my breakpoints), and the page just loads unimpeded. 
I've tried the internal browser, IE6 and Firefox, all result in the same

The following appears in the console (the last two lines after a pause,
by which time the script has run, and the page loaded in the browser).

Found default config file
Server started on 5014
LOG: 5 5014-server: main.: starting handler: cgi
LOG: 5 5014-server: main.: starting handler: file
LOG: 4 5014-server: new connection
LOG: 3 5014- Request 24 GET /index.html HTTP/1.1
LOG: 5 5014- main.: invoking handler: cgi
LOG: 5 5014- cgi. suffix=.pl root=G:/Web/cgi-bin url: /index.html
LOG: 5 5014- Checking for suffix: .pl
LOG: 5 5014- cgi. looking for: G:\Web\cgi-bin\index.html.pl
LOG: 5 5014- main.: invoking handler: file
LOG: 5 5014- file.: Looking for file: (G:/Web/htdocs)(\index.html)
LOG: 3 5014- request done
LOG: 3 5014- Error: 408 Request Time-out: Read timed out
LOG: 4 5014- socket close


My webserver is apache 2.0.

Any ideas what the problem could be?

Thanks in advance,


jploski wrote on Wed Sep 28 20:52:15 MEST 2005:
Based on the output you quoted, no CGI script is ever being executed. The
EPIC's built-in web server seems to be serving the file index.html to the
client. If no CGI script is run, it is no wonder that the debugger does
not stop anywhere, right?

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.