Taint mode in CGI Debugging

gregaryh wrote on Fri Sep  1 01:35:31 MEST 2006:
I am trying to use the debugger to debug my CGI application. I use taint
mode on the shebang line (#!/usr/bin/perl -wT). When I run debugger I get
"-T" is on the #! line, it must also be used on the command line at 

I have checked the use Taint mode in the preferences and even tried adding
-wT to the Perl executable. Neither seems to make any difference. I can
debug successfully if I remove the -T from the file, but then I often forget
to put it back before I check it in.

Am I doing something wrong? 
I also get the "Too late for -T" error on the first line of all my cgi files.

I am running epic 0.5.0 on eclipse 3.2 on Linux
jploski wrote on Fri Sep  1 08:27:11 MEST 2006:
You're doing nothing wrong. So far, there is simply no way to pass command-line
parameters to the Perl interpreter in CGI mode and the "Enable warnings"
and "Enable taint mode" preferences are also ineffective in this context.
You should open a request for enhancement.

A workaround which might also work is a wrapper script (which passes -T
correctly) to be used instead of the real interpreter by EPIC.

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.