Why my ecplise does not open the debug port

sleepy_wang wrote on Fri Nov 24 02:46:46 CET 2006:
I am working on Eclipse 3.2, perl 5.8.8 and the latest EPIC (downloaded
yesterday). When i configured the remote debug according to the tutorial
and launch it through the debug button, I found out that the debug port
does not be listened, checking it with "netstat -an", without any error
report. And when I start the start_epicDB.pl from  the target box, the program
complains can not connect the port. 

My questions are:
1. I suppose to check the port on local box, which runs the ecplise, Is
my understanding right? 
2. I tried to change the port to some other value, after I read some previous
discuss, but all failed. Is there any one knows why the port does not be
3. Is there any log to check for EPIC?

Thx in advance. 
jgangemi wrote on Fri Nov 24 04:15:46 CET 2006:
there's a good chance that code is just broken - perhaps jan can comment

i'm planning on taking a look at this code over the holiday as well.
sleepy_wang wrote on Mon Nov 27 04:27:12 CET 2006:
Jan, thanks for taking care of this issue. 
I tried it on a solaris box, and don't find the port either.... 
And on both platform, i met a "internal error" dialog when i tried to stop
the started remoted process... 
jploski wrote on Sun Dec  3 20:12:11 CET 2006:
Please try with 0.5.23. At the very least, the error logging should be improved.
Read the "Perl Remote" section in the online help included with 0.5.23 for
details about how the ports are handled.
sleepy_wang wrote on Wed Dec  6 09:05:30 CET 2006:
Jan, thx for keep working on this issue.

I only find the source version of the 0.5.23, and i must admit that i am
not sure how to compile it. Is there any compiled 0.5.23 version online?
jploski wrote on Wed Dec  6 18:54:54 CET 2006:
0.5.24 is available through http://e-p-i-c.sf.net/updates/testing
You should be able to install it using the Update Manager as described in
the user's guide.

0.5.23 is there as well, but you should not use it as it contains a rather
nasty bug in the debugger (variables don't appear at all in Eclipse 3.2).
sleepy_wang wrote on Thu Dec  7 11:24:39 CET 2006:
Jan, Thanks....downloaded it and the port is listened now....will try the
real debug tomorrow.:)
sleepy_wang wrote on Mon Dec 11 03:29:47 CET 2006:
Jan, it works fine here....with a simple test. :-)

Still not clear about the display and some other stuff, i would like to
learn it by myself.

Thanks for your great work.

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.