CGI debugger broken

linux_linux wrote on Tue Jun 24 22:54:36 MEST 2008:

EPIC is a great product however, I am having trouble with the CGI debugger.
The odd thing is, it worked for me for about a month, and then it quit,
and I am not able to make it work. Here is the situation:

Suse Enterprise 64bit
EPIC 0.6.24 (also tried 0.6.20)

For perl local debugging, everything works. Padwalker, debug console, etc
etc. For Perl CGI, I can Run the project from Eclipse and everything works.
However if I Debug the same project I get a popup window saying EPIC Error:
Could not connect to debug port! and the web server and CGI process terminate.
I get no debug console in this case.

I tried using either the internal browser or Firefox. Same error either
way. I looked around for log files and found a few but, nothing seems to
relate to the debugger.

Does anyone have an idea how to solve this or where to look next?

jploski wrote on Tue Jun 24 23:01:14 MEST 2008:
It could be related to your firewall/network setup, but it could also be
that the Perl interpreter exits before your CGI script is executed. To eliminate
the second possibility, try debugging a CGI hello world project.
linux_linux wrote on Tue Jun 24 23:55:01 MEST 2008:
Thanks for the quick reply!

I did check with the server admin and according to him there is no firewall
and the networking hasn't been changed. I'll still keep my eye out for such

My first script wasn't exactly a HW but now it should be close:

use CGI;
my $cgi = CGI->new();    
print $cgi->header();
print "Hi there
"; print $cgi->end_html(); In the usual case I get the Could not open port error and I get no output in the CGI console and just minimal output in the Web console and nothing in the Eclipse error log. However on one particular run I did get an Eclipse error. I don't know if it means anything but I'm including it anyway. I'll keep digging, let me know if there is anything else I can try... Larry org.eclipse.debug.core.DebugException: Breakpoint does not have an associated marker. at org.eclipse.debug.core.model.Breakpoint.ensureMarker( at org.epic.debug.PerlLineBreakpoint.getLineNumber( at org.epic.debug.db.PerlThreadBreakpoints.removeBreakpoint( at org.epic.debug.db.PerlThreadBreakpoints.access$4( at org.epic.debug.db.PerlThreadBreakpoints$1.breakpointRemoved( at org.eclipse.debug.internal.core.BreakpointManager$ at at org.eclipse.debug.internal.core.BreakpointManager$BreakpointNotifier.notify( at org.eclipse.debug.internal.core.BreakpointManager.fireUpdate( at org.eclipse.debug.internal.core.BreakpointManager.removeBreakpoints( at org.eclipse.debug.internal.core.BreakpointManager$BreakpointManagerVisitor.update( at org.eclipse.debug.internal.core.BreakpointManager.resourceChanged( at$ at at at at org.eclipse.core.internal.resources.Workspace.broadcastBuildEvent( at at at Session data: eclipse.buildId=M20071023-1652 java.fullversion=J2RE 1.5.0 IBM J9 2.3 Linux amd64-64 j9vmxa6423-20061001 (JIT enabled) J9VM - 20060915_08260_LHdSMr JIT - 20060908_1811_r8 GC - 20060906_AA BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US Command-line arguments: -os linux -ws gtk -arch x86_64
jploski wrote on Wed Jun 25 20:10:05 MEST 2008:
You wrote you checked with the "server admin" - are you running Eclipse
on this server? (It is the firewall/networking of the machine on which you
execute Eclipse that is relevant.)

You could try switching to Sun's JVM (just a blind guess). You could try
sniffing with tcpdump/snort on TCP ports 5000-5004 to see whether communication
attempts are made (connection from the Perl interpreter to EPIC listening
on these ports). You could try figuring out how the Perl interpreter is
invoked by EPIC's embedded Brazil web server and making sure that it (the
Perl interpreter) doesn't fail for some reason if invoked in the same way.
linux_linux wrote on Thu Jun 26 05:52:44 MEST 2008:
Ah yes, actually what we have is a server running Suse Enterprise Desktop,
and then all the developers use remote X to get a desktop either using cygwin
on windows, or else using a local linux box. It's so we only have one development
environment to administer.

I'll try looking at the network traffic and see if I can find anything.

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.