Eclipse 3.1.1 + EPIC 0.3.x + Win XP - Perldoc

kaymcfly wrote on Mon Jan 23 16:17:17 CET 2006:

after a few hours of searching I decide to ask here for help. I know that
I'm not the only one with this problem, but I don't find any answer.

If I want to use the Builtin Perldoc of the EPIC Plugin, one or more DOS
Boxes will be opened. It ends with "Documentation not available".

I use ActiveState 5.8.7 and in Systems Path I can find c:\perl\bin where
the perldoc program is located.

I think, it is only a little mistake in my configurations and one or two
sentences will help me. 

Thank you for your answers...

jploski wrote on Mon Jan 23 19:11:09 CET 2006:
Check if the following snippet works when executed as a standalone script:

use Env qw(@PERL5LIB);

push(@PERL5LIB, @INC);
exec('perldoc -t -f "open"');

This is basically what EPIC uses to obtain the documentation for function
"open". If it doesn't work for you, look for the reason and maybe your solution
will fix the problem in EPIC too.
terrator wrote on Tue Jan 24 17:25:25 CET 2006:
I too have a problem with Perldoc in Eclipse.

Epic finds the perldoc documentation all right but it doesn't display in
the Perldoc view; it opens a CLP and displays the documentation there.

I have tried the snippet from the CLP in WinXP and it works fine.

Any other ideas as why the output of perldoc is not redirected to the perldoc
view in eclipse?


jploski wrote on Tue Jan 24 19:29:06 CET 2006:
Tell me which version of EPIC you use.
kaymcfly wrote on Wed Jan 25 14:21:36 CET 2006:
Hi Jan,

thank you for answering. 

Last week I had installed the stable version 0.3.0. Now I have tryed to
fix the problem with Perldoc and take the 0.3.12. This is why I wrote 0.3.x.
I think, it is the same problem as described by terrator and some other
people such as jimbojones2000 here. 

Thanks for all ideas.

paulflory wrote on Wed Feb  1 04:46:49 CET 2006:
I had the same problem on Win2000 with the numerous DOS windows... until
I installed EPIC 3.12 and changed the perl executable to "C:\Perl\bin\perl.exe"
rather than wperl.exe, against the recommendation in the docs, in the EPIC
preferences.  Then I could view perldocs within Eclipse, as desired.   

Let me know if that works for you,
jploski wrote on Wed Feb  1 09:20:09 CET 2006:
I have never used wperl.exe as the interpreter under Windows XP - and I've
had no problems with PerlDoc either. I tried now and the console windows
indeed appeared. This is strange as wperl was meant to solve precisely this
kind of problem (according to Google).

Anyway, everyone follow Paul's advice and see if that helps.
kaymcfly wrote on Wed Feb  1 09:56:15 CET 2006:
Wow, it is so crazy. Paul - Thank you. It works. I ask myself, why I don't
try this way. After installation the default value was c:\Perl\bin\perl.exe.
Because this had no worked, I had tryed ...\wperl.exe. After this I upgraded
to 0.3.12, but I don't change the interpreter value back. In any way - you
have helped me.

Thank you again for all answers and sorry for my bad English. 


Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.