I cannot add repositories

per157 wrote on Fri Aug  8 21:25:49 MEST 2008:
Hi all,

This is a newbie question, that gives this particular newbie a nice good
old-fashioned headache!

I cannot add any site as repository of modules either local or web-based.
For example I have tried the following repositories and each and every time
I get as an answer that a repository doesnt exist in that address.


I am runing perl 5.8.8 in MacOs 10.5 with EclipseSDK 3.4 and EPIC 0.4.5.
The installation was without any errors reporing and I followed the instructions
that came with Eclipse and EPIC.

Many thanks! 

jploski wrote on Fri Aug  8 21:31:43 MEST 2008:
Where are you trying to add these sites? (Certainly not in EPIC?...)
Where did you get EPIC 0.4.5 from? The current version is 0.6.24.
per157 wrote on Sun Aug 10 12:33:03 MEST 2008:
Hi jploski,

I think I got EPIC from here.
But really I do not remember

Anyway I got the 0.6.13 version now but when I try to update to the 0.6.24
I am getting exactly the same message like the next question in the help

An error occurred while collecting items to be installed 
No repository found containing: org.epic.debug/osgi.bundle/0.6.18 
No repository found containing: org.epic.feature.main/org.eclipse.update.feature/0.6.24

No repository found containing: org.epic.lib/osgi.bundle/0.6.1 
No repository found containing: org.epic.perleditor/osgi.bundle/0.6.16 
No repository found containing: org.epic.source/osgi.bundle/0.6.24 

Despite the fact that when I am at the repositoy screen the 0.6.24 appears
in the list of modules.

As for the why I was trying to install these sites:
I tried to get Padwalker but since I have no big experience in manual installation
of packages (actually none at al)  I tried to install it via the Eclipse
install feature. After I failed to install it through a repository (where
I knew that it existed) I tried to add some other repositories (the list
I gave) in order to be sure that there was no problem there.

And there I found out that I could not add any repository at all.

Any help will be apreciated!

jploski wrote on Sun Aug 10 12:49:41 MEST 2008:
Have you tried a clean installation? I mean: Uninstall EPIC using the Help/Software
Updates... dialog or simply by deleteing $ECLIPSE_HOME/plugins/org.epic.*
and $ECLIPSE_HOME/features/org.epic.* (while Eclipse is not running). Then
restart Eclipse, open Help/Software Updates... and select "Add update site...".
Enter http://e-p-i-c.sourceforge.net/updates/testing, tick it and click
on "Install...".

As for PadWalker and the other repositories you mentioned: these repositories
are Perl module repositories, not Eclipse plug-in repositories accessible
by the Update Manager. There is no sense in adding them to Eclipse. If you
are under Windows and using ActiveState Perl, the easiest way to install
PadWalker is to use the PPM package manager GUI. Some additional tips are
in the FAQ.
per157 wrote on Mon Aug 11 10:14:47 MEST 2008:
I did the clean install and I have 0.6.24 now.

Ok I see your point concerning the Perl repositories. It made things muchclearer.
Concerning PadWalker I am using mac os X. Is there something equivalent
to the PPM Packager Manafer GUI you are suggesting?

jploski wrote on Mon Aug 11 19:09:42 MEST 2008:
I'm not sure about Mac OS X in particular. Unix installations of Perl in
general have the so called CPAN shell, which can be used to install anything
straight from the CPAN repository.

As root user you can start it with "perl -MCPAN -e shell" in the terminal,
then enter "install PadWalker" to download and install the module and all
its dependencies. While this is quick and convenient (after you've gone
through the one-time series of configuration questions), it may cause minor
problems if you decide to update your OS later on. Basically, the Perl modules
installed in this way may become deleted during an OS upgrade, in which
case you'd have to reinstall them.
per157 wrote on Tue Aug 12 10:39:02 MEST 2008:
Thanks! That was a really usefull piece of information that if I may say,
is not very well published in the CPAN site for the noble population of
newbies, of which I am a proud member!

I did as you said, it worked very nicely but it stopped due to a problem
with access rights. I will now ask in the CPAN forums how to continue from

Thank you again for all this info, it was really usefull!!!

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.