@INC no longer working

o190 wrote on Wed Dec  6 17:30:50 CET 2006:
I have the modules in the same path as the perl scrips.


My Script says:

use strict;
use CGI;
use perlmodule;

Since some days I get the error:
"Can't locate perlmodule.pm in @INC (@INC contains: D:/xampp/xampp/perl/lib
D:/xampp/xampp/perl/site/lib .)"

I changed nothing in the code but I upgraded EPIC. Version now is 0.4.24
I have problems with two pc's. One with Win XP and one with Win 2000.

I also tried adding the path with Project->Properties.

I entered three pathes:


But when I checked with this code:

foreach (@INC) {
 print "$_\n";

I only got this result:

The additional pathes are ignored!
The path '.' is also ignored!
It should normally point to the program-dir itself.
But its also ignored.

What can I do?
jploski wrote on Wed Dec  6 19:11:45 CET 2006:
I find it hard to believe that an upgrade caused this problem because nothing
has changed in the @INC path handling recently. Also, I cannot reproduce
the problem on my machine (Linux not Windows, though). If you know Java,
then you should be able to debug the problem yourself. Set up the debugger
as described in http://e-p-i-c.sf.net/devguide/devguide.html (Hacking EPIC
in 15 Minutes) and set a breakpoint in method PerlProject.getIncPath.

You can also downgrade to see if it helps.
o190 wrote on Thu Dec  7 16:04:10 CET 2006:
Hi Jan,

thanks for responding. Sorry. I have zero knowledge about Java. I use Eclipse
only as Perl-IDE (at rookie-level). When I run the code that causes the
error within EPIC from the commandline then everything is running perfect.
So I think it's not a syntax issue.

Note: The above is an archived snapshot of a forum thread. Use the original thread at sf.net to post comments.