Problem while installing EPIC on E 3.2.2

serggulko wrote on Mon Jun  4 10:07:58 MEST 2007:

I tried to install EPIC on my Eclipse 3.2.2 and have next error:

Resulting configuration does not contain the platform

I tried to run installtion with debug and stable versions and for both have
similar error.
Any idea how to solve it?

jploski wrote on Mon Jun  4 19:01:54 MEST 2007:
Maybe you installed the version of Eclipse without JDT? In such case, try
installing Eclipse with JDT. Theoretically, EPIC does not require JDT, but
there might be some hidden dependency lurking somewhere.
serggulko wrote on Mon Jun  4 22:40:09 MEST 2007:
No, I already have JDT installed(3.2.2) and also JDT SDK... Maybe I need
re-compile epic for my platform?
jploski wrote on Mon Jun  4 23:36:06 MEST 2007:
There is no platform-specific code in EPIC, so no need to recompile. How
did you install - using the update manager or by downloading and unpacking
EPIC? Both ways should work, but maybe try another route to see if it fails.
You can also go to Manage Configuration in menu Help and check that all
features are enabled (if you can start Eclipse at all, that is).
jploski wrote on Mon Jun  4 23:43:48 MEST 2007:
When experimenting with different installation methods, it may be useful
to uninstall EPIC first...
1. Close Eclipse
2. Delete plugins/org.epic.* and features/org.epic.*
3. Restart Eclipse with the command-line parameter "-clean"
serggulko wrote on Tue Jun  5 23:33:57 MEST 2007:
Take a look on this error...Do you have any idea?

!ENTRY org.eclipse.update.core 4 0 2007-06-06 00:27:45.445
!MESSAGE Unable to retrieve remote reference "".
[Server returned HTTP response code: "404 Not Found" for URL:]
org.eclipse.update.internal.core.FatalIOException: Server returned HTTP
response code: "404 Not Found" for URL:
	at org.eclipse.update.internal.core.UpdateManagerUtils.checkConnectionResult(
	at org.eclipse.update.core.ContentReference.getInputStream(
	at org.eclipse.update.core.FeatureContentProvider.asLocalReference(
	at org.eclipse.update.internal.core.FeaturePackagedContentProvider.getFeatureEntryArchiveReferences(
	at org.eclipse.update.internal.core.FeaturePackagedContentProvider.getFeatureManifestReference(
	at org.eclipse.update.internal.core.FeaturePackagedFactory.createFeature(
	at org.eclipse.update.core.Site.createFeature(
	at org.eclipse.update.core.FeatureReference.createFeature(
	at org.eclipse.update.core.FeatureReference.getFeature(
	at org.eclipse.update.core.FeatureReference.getFeature(

!ENTRY 4 2 2007-06-06 00:28:45.679
!MESSAGE An internal error occurred during: "Update Manager".
java.lang.ArithmeticException: / by zero
	at org.eclipse.update.internal.ui.views.FindUpdatesAction$TrackingProgressMonitor.updateStatus(
	at org.eclipse.update.internal.ui.views.FindUpdatesAction$TrackingProgressMonitor.beginTask(
	at org.eclipse.update.ui.UpdateJob.runUpdates(
	at org.eclipse.update.internal.ui.views.FindUpdatesAction$
jploski wrote on Wed Jun  6 18:56:43 MEST 2007:
The first error can be safely ignored (will be fixed in a future release
of stable nonetheless). The second one looks bad. Have you also tried installing
the "testing" version of EPIC (via update site
jploski wrote on Wed Jun  6 19:07:39 MEST 2007:
There is an open bug report in Eclipse regarding the ArithmeticException,

However, no explanations or solutions there.

I hope that you are following the installation instructions from the EPIC
User's Guide and/or the README contained in the downloaded update site file,
not unpacking this file into $ECLIPSE_HOME directly, or unpacking the contained
jars, or doing anything strange like that.
serggulko wrote on Wed Jun  6 23:51:58 MEST 2007:
Finally I have found what was wrong with installation... 

Take a look(i am running 3.2.2)

EPIC (0.6.6) requires feature "org.eclipse.platform (3.2.0)", or compatible.

Any ideas?
jploski wrote on Thu Jun  7 10:35:08 MEST 2007:
Well, it's true, the testing version of EPIC requires at least Eclipse 3.2,
as stated in documentation. Nothing wrong with that.

The feature org.eclipse.platform belongs to Eclipse, check out the subdirectories
under $ECLIPSE_HOME/features, there should be one called org.eclipse.platform_3.2.0.v20060609m-AgOexn6hlEUsvBO
or the like. Are you saying that YOUR version of org.eclipse.platform is
not considered "compatible" with "3.2" by Eclipse?

In any case, you can edit $ECLIPSE_HOME/features/org.epic.feature_XXX/feature.xml
to remove the declared dependency on org.eclipse.platform if you think it
causes the problem. However, as noone else seems to have that problem, I
suspect that it's something specific to your environment rather than to
EPIC's feature.xml.
dewarim wrote on Sun Jun 10 19:22:44 MEST 2007:
I am unable to install EPIC too, neither the stable nor the testing version
works for me:

  ----- Current configuration problems -----
    Resulting configuration does not contain the platform.
  ----- Configuration problems after the operation -----
    Resulting configuration does not contain the platform.
    EPIC (0.6.7) requires feature "org.eclipse.platform (3.2.0)", or compatible.

Eclipse reports itself as 
Version: 3.2.2
Build id: M20070212-1330 (Fedora release 6.93 (Rawhide))

I also could not find a dependency on a specific eclipse platform in org.epic.feature_XXX/feature.xml
(on stable) - are you sure this is the correct file?
jploski wrote on Sun Jun 10 19:37:01 MEST 2007:
> I also could not find a dependency on a specific eclipse platform
> in org.epic.feature_XXX/feature.xml (on stable) - are you sure this is
the correct file?

There is no dependency in 'stable'. The dependency is only stated explicitly
in feature.xml of 'testing'.

You may want to experiment by removing this dependency altogether or by
changing match="compatible" to match="greaterOrEqual", which is the fuzziest
match possible.
dewarim wrote on Mon Jun 11 20:12:03 MEST 2007:
I have been successful installing EPIC on a fresh install of vanilla Eclipse
3.2.2 in ~/eclipse/...
It seems that the problem lies within the Fedora-7-package of Eclipse.
jploski wrote on Sun Jun 10 19:40:35 MEST 2007:
BTW, your Eclipse build id is exactly the same as mine, so it should work.

You can also go to Help/Software Updates/Manage Configuration and check
if the features listed there do not appear as disabled or strange in some
way (remember to click on the "Show Disabled Features" button in that dialog).
This is also where you can disable/enable and remove features in an organized
way. Restarting Eclipse with the "-clean" switch on the command line is
another idea which might help.

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.