Problem with EPIC + Eclipse 3.0.1 :(

sabitov wrote on Mon Dec  6 05:51:31 CET 2004:
Does anybody try to run EPIC under Eclipse 3.0.1? 

It crashes for me with such exception: 

java.lang.NoClassDefFoundError: cbg/editor/ColoringSourceViewerConfiguration
davidwpowell wrote on Mon Dec  6 06:06:52 CET 2004:
Yes to your question - but I get no exception incident.  Someone else may
have more useful advice.  Maybe more details of your environment would be
useful (From Help>About Eclipse Platform>Feature Details, the entry "Perl
Editor Plug-In" shows 0.3.0.  I'm running Windows 2000 SP 4.)
leo_forge wrote on Mon Dec  6 10:21:36 CET 2004:
Seems like not everything installed. What the error refers to is about the
coloring-interface which makes nice keyword-colouring. So, I would guess,
you have *crippled* installation.
sabitov wrote on Tue Dec  7 06:12:09 CET 2004:
It's funny, but I get this error under Linux only.
It does not depend what version I use. 

I've tried to install it several times from zero, with the same result.
I do it such way (possibly I wrong?):

1 unpack eclipse .zip 
2 unpack eclipse's native plugins cdt, gef, uml2 
3 unpack EPIC. 

Also, I tried to install EPIC via "Software Updates", the same result.

run /opt/eclipce/eclipse -clean, exit, run it again w/o -clean switch. 

Then go to, Window -> Preferences -> Perl EPIC -> Editor.

pljones wrote on Wed Dec 29 18:00:38 CET 2004:
I just posted this bug:
I was trying to run with Eclipse 3.1M4 and Java 5.
pljones wrote on Fri Jan 14 19:05:54 CET 2005:
See my update to the bug report: I cleared out everything EPIC related I
could find then re-installed 0.3.8 (from the update site, via Eclipse's
update thingy) and it's working now.

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.