Debugger doesn't break at breakpoints

kororos wrote on Wed Dec  1 14:09:12 CET 2004:

I am using Eclipse 3.1, EPIC 0.3.0 and Perl 5.6.1 on a Win2000 machine.
The plugin works fine in all the situations apart from breaking on breakpoints.
The debugger does not stop at breakpoints. I don't get any error messages.

Any help would be appreciated.


sagro wrote on Wed Dec  8 15:17:35 CET 2004:

i have the same problem.
i am using eclipse platform 3.0.1 and activeperl on a w2k machine.
when i start a debug session in a perl cgi environment the debugger does
not stop at breakpoints.


kororos wrote on Wed Dec  8 15:22:33 CET 2004:
Hi sascha, 

since I posted the above message I worked out what I was doing wrong. I
though, I'll share it with you since you are having similar problems. 

The problem was that when I right-click on the line that I want to put the
breakpoint at, I was selecting the first option from the context menu (it
reads "Breakpoint"). However, I realised that if I select the second option
in the context menu (it also reads "Breakpoint" - don't know why there are
two!), then it worked fine. 

Hope this helps you,


sagro wrote on Thu Dec  9 08:45:02 CET 2004:
hi terry,
my context menu has two options 'add breakpoint' and 'add regexp breakpoint'.
i tried both and the debugger has not not stoped.

pythonologist wrote on Tue Dec 28 02:10:56 CET 2004:
My context menu has 3 options Add Breakpoint, Add Breakpoint, Add RegExp
Breakpoint and none of them work. Eclipse 3.1, Epic 0.3.0, Perl 5.8.4, JVM
1.5.0, W2K.  The debugger stops at the breakpoints but no stack frame is
displayed. I can stop on a RegExp and it switches to the RegExp pane but
nothing is displayed there. If I enter an expression, it pops up "Choose
Context Stack Frame", but there are none to choose. I believe I have the
right PadWalker. Ideas?
vihonh wrote on Sun Apr  3 04:03:20 MEST 2005:
Hi All,
I have the same problem - no breakpoint hits, no matter which I use.  I
am running ActiveState Perl with Eclipse 3.1M5a and the latest
EPIC - 0.3.10.  I installed what looks like the correct PadWalker and no
longer have those problems.  Using Windows XP SP2.  Any ideas?
dkroot wrote on Tue Jun 28 23:09:39 MEST 2005:

it definitely looks like EPIC/Eclipse 3.1 compatibility problem. I'm running
both Eclipse 3.0 and Eclipse 3.1 RC3 on the same machine and on 3.0 debugger
works just fine. (WinXP, ActiveState Perl On 3.1 both EPIC 0.3.0
and 0.3.10 enter debugging mode but have Step Into / Step Over, etc. disabled,
do not have current line indicator, so basically do not work.

Note: The above is an archived snapshot of a forum thread. Use the original thread at to post comments.